Page MenuHome

Clipped/sharp borders lighting by objects with cycles emission textured shader
Closed, ResolvedPublic

Description

System Information
Windows 7x64, Nvidia Gtx580

Blender Version
Broken: blender-2.79.0-git.ac28a4f-windows64 and later
Worked: blender-2.79.0-git.535e836-windows64

Short description of error
Clipped/sharp borders lighting by objects with cycles emission textured shader.

Exact steps for others to reproduce the error
1 Add two planes (1 textured emission + 1 diffuse)
2 Clipping on light border


Details

Type
Bug

Event Timeline

Brecht Van Lommel (brecht) lowered the priority of this task from Needs Triage by Developer to Normal.Aug 21 2017, 7:12 PM

@Stefan Werner (swerner), I think this one is for you.

Sergey Sharybin (sergey) triaged this task as Confirmed, Medium priority.

Indeed caused by rB8141eac.

Thanks for the report. It looks like the UV coordinates for mesh lights are off when using spherical sampling.

Stefan Werner (swerner) closed this task as Resolved.Aug 30 2017, 12:55 PM