Blender unstable when using GPU Compute in any situation
Closed, DuplicatePublic

Description

System Information
Windows 10 Creator's Update
4770k
EVGA GTX 1060 3GB
8GB DDR3

Blender Version
Broken: 2.78c, 2.79 RC2

Short description of error
When using GPU Compute to render in any situation, whether it be actually rendering or just in render preview, Blender becomes really unstable and will either crash or turn all the panels either black or gray, as shown here and then eventually crash. CPU rendering works fine, however it is slower and it's annoying that I cannot take advantage of my GPU in Blender. This issue happens consistently every time I use the GPU Compute to render, no matter the project. Other users detail the same issue here, and also are using Pascal cards. I've tried reinstalling Blender multiple times, updating drivers, and have also tried 2.79 RC2 to find no improvement to my issue. I am a beginner in Blender so I cannot say if I have experienced this issue on older versions.

Exact steps for others to reproduce the error
Use GPU Compute to render in any situation, presumably on a Pascal card with recent drivers

Details

Type
Bug
Bastien Montagne (mont29) triaged this task as Incomplete priority.

@Sergey Sharybin (sergey) not sure who handles that kind of issues? But maybe you’d at least have the hardware at the studio to try to reproduce?

@Eldrick (Pr3cast) Please always attach a small and simple .blend file to help reproducing the issue, always saves us a tremendous of time.

Eldrick (Pr3cast) added a comment.EditedAug 27 2017, 6:33 PM

As I said, this issue occurs no matter what I'm working on, simple or complex. But here, I attached a file that almost immediately produced the issue for me

Bastien Montagne (mont29) raised the priority of this task from Incomplete to Normal.Sep 5 2017, 12:55 PM
Sergey Sharybin (sergey) lowered the priority of this task from Normal to Incomplete.Sep 5 2017, 2:25 PM

Guess you've meant "Compute", not "Composite".

I can not reproduce the issue on Windows 10 with GTX1080. We've got 1060 in the studio, but it's in Linux machine, but it works just fine. Driver i uses is 385.41.

Please download same driver version from nvidia.com site, install it and see if that helps.

In any case, we can't do any "scheduling" in Blender to make interface more or less responsive during CUDA render, it is all in driver and operation system control. So you might also want to go through driver settings or so.

Bastien Montagne (mont29) closed this task as Archived.Sep 14 2017, 4:46 PM

More than a week without reply. Due to the policy of the tracker archiving for until required info/data are provided.

385.41 made no visible difference on the issue, unfortunately. I haven't really made any changes to my graphics settings, and if there was an issue with my OS that could be the problem, I haven't noticed it yet.

@Bastien Montagne (mont29) I've posted a while ago, any update?

I also have the same problem. Any new information on this issue?
My System: i5-2500k, GTX 1060 6GB, 20GB DDR3 RAM
nVidia driver version: 385.28
OS: Windows 10 Pro

Brecht Van Lommel (brecht) renamed this task from Blender unstable when using GPU composite in any situation to Blender unstable when using GPU Compute in any situation.
Brecht Van Lommel (brecht) reopened this task as Open.
Brecht Van Lommel (brecht) updated the task description. (Show Details)

Some things to try:

When Blender crashes, that means Blender closes without any error message? Or does the render stop and show some kind of error message, and if so what is the message? When does it crash, immediately when you press render, while it is rendering, when editing materials, .. ?

Already tried latest build and drivers. It doesn't seem to have any rhyme or reason. Whenever the view panel is re-rendered or a final image is being rendered, it will crash sooner or later, no matter what action took place, whether it be a movement of the camera, a material change, mesh edit, etc. By 'crash', I mean that the program freezes and this generic Windows dialog shows up: https://i.pr3cast.pw/10.19.17.Jz.png. Is there a log file you'd like me to look in?

Have you tried checking the "Clean installation" box when installing the NVidia drivers? The blenderartists thread also mentions turning of the "Nvidia In-Game Overlay", and there may be more options in the NVidia settings that have an effect.

Currently we have no way to reproduce the issue, it seems some user have this while others don't. We need to figure out where the difference is, but so far it's unclear.

There isn't really any useful log file for inspecting this.

I'll try that out this weekend.

I can reproduce the NVidia In-Game Overlay starting when doing a Cycles render, though no crash, only a useless "Press Alt-Z to begin sharing.." message. It's suspicious at least, and has been reported to NVidia now.

Closing as duplicate of another bug. It's still a mystery why some users are having this problem, we're trying to figure it out.