Page MenuHome

bake from selected to active gives results that seem bogus
Closed, InvalidPublic

Description

System Information
Linux bubastis 4.0.5-gentoo #2 SMP Tue Jan 3 15:53:31 EST 2017 x86_64 Intel(R) Core(TM) i7-4800MQ CPU @ 2.70GHz GenuineIntel GNU/Linux
01:00.0 VGA compatible controller: NVIDIA Corporation GK107GLM [Quadro K1100M] (rev a1) (prog-if 00 [VGA controller])

Blender Version
Broken: blender-2.79-rc1 and 2.78c

Short description of error
Attempting to bake from selected to active malfunctions for a group of cylinders.

Specifically "tank lower"* and "tank upper" selected_to_active "tank cluster bake 1".

Exact steps for others to reproduce the error

Select the above-mentioned cylinders that are children of "tank cluster A" and make sure that "tank cluster bake 1" is active. Then use the Bake button in the render panel. The necessary material node and UV map are already active.

The resulting image is not suitable for use as a baked texture (for example on "tank cluster bake 1.002")

Details

Type
Bug

Event Timeline

Except bad settings and scene set-up, I see no bug, here.

It does not make sense to make a huge margin of 16 px if there is only a space for 2 pixels between UV Islands.
Then, you have to precise a ray distance different from 0 or use another mesh as a cage to precise clipping the same way your camera for common renders has clipping values.
Set it to a distance of 0.1 and you should obtain a decent result.

The distance=0.1 solved the problem on 2.79 rc1 .

I got a SEGV in 2.78c, but we probably don't care about that with 2.79 on the way.

Bastien Montagne (mont29) closed this task as Invalid.
Bastien Montagne (mont29) claimed this task.

Closing then. Note that we do not handle user support on this tracker, only bug reports. User forums like blenderartists.org or blender.stackexchange.com should be used for that matter.