Page MenuHome

Compositing: Artefacts on tile borders when using filters
Closed, ResolvedPublic

Description

System Information
Win10 x64, nVidia GTX 1080Ti

Blender Version
Broken: 2.78c, 2.79RC2, Buildbot builds, own builds
Worked: none so far

Short description of error
Yesterday I had to upres some rendered pictures to match 4k footage. I used the Scale node set to "Render Size".
Incoming footage and render size was at 4096x2304, rendered pictures were half res ( 2048x1152).
I noticed that the upscaling looked terrible, like a simple nearest filter. (It would be nice to offer a selection of filters for scaling BTW, just like in the transform node).
The rendered stuff I had to upscale was just some blurry glows and light strokes, nothing too detailed or fancy. So I added a simple filter node set to "Soften" before the scale. It did the job, everything was smooth and it kind of matched the camera footage which looked a bit blurry as well.
But then I noticed ugly vertical and horizontal lines. The distribution varied with the tile size I set for the comp. The default of 256x256 gave me fewer of these lines than e.g. 64x64. They only appeared when using the filter before the scale node. They also show up when you put a blur node before the scale, even with a blur size of 0. I didn't try any other nodes because of lack of time, but I suspect there are others showing this behaviour as well. I don't know if it's the filter node's fault or the scale.
The "lines" show up both the the RGB and in the alpha channels. As a quick "fix" I used an Inpaint node to fill the gaps but this isn't a real solution.
This kind of bug also exists in older versions of Blender so it's not a regression.

Here's an example of this pattern. It's just an image with a constant colour scaled up 2 times.

Exact steps for others to reproduce the error

  • Open the attached blend file
  • Go to Compositing Layout and CTRL+SHIFT click the scale node to refresh the Viewer
  • See the ugly black lines
  • Switch the viewer to show the Alpha channel -> Ugly lines as well
  • Detach the Filter node and attach the Blur node instead: Same result
  • Change the tile size for the comp -> watch the grid like pattern become larger of smaller
  • Mute the Filter or the Blur node: Clean result

EDIT: After sending this ticket I noticed that the attached PNG uses the transparency of the alpha channel in the browser. You have to look closely but the lines are visible.

Details

Type
Bug

Event Timeline

Dalai Felinto (dfelinto) triaged this task as Confirmed, Medium priority.Aug 29 2017, 11:40 AM

Confirmed here. That said, If you use the scale node BEFORE the other nodes things work fine.

Thanks for confirming this. Yes, it "works" when scaling first, but in my case all the filters were set to a specific look and I was about to start the playout for the final delivery of several shots in 4k when all of a sudden I noticed this bug.
In the end I started resizing all of the render pictures with Fusion.

These lines appear when determining the area of interest. Not sure why we never seen this one failing. But I added 1 pixel slack to the maxx and maxy side. Also tested with other resolutions and other tile orders.

Jeroen Bakker (jbakker) closed this task as Resolved.Sep 3 2017, 4:58 PM