Flipped names don't weight properly with Mirror Modifier
Closed, ArchivedPublic

Description

Blender Version
Broken: Blender 2.79 rc2 7b397cd
Worked: Blender 2.78

When making a mesh that utilizes the Mirror Modifier a child of an armature that has flipped names (i.e. Made the left side of the armature, duplicated all the bones and scaled -1 to get the right side, used Flip Names to fix the names) the weighting will not be correctly mirrored for bones that had their names flipped.

Exact steps for others to reproduce the error

  1. Create a Cube, cut it in half from forward view, delete the left half.
  2. Add the Mirror Modifier to the Cube to make a whole cube.
  3. Create a Single bone.
  4. In Edit Mode for the Armature, move and scale the bone to align with the 'real' half of the cube.
  5. Name the Bone 'Bone.L'
  6. Ensure the 3D cursor is centered and set the pivot to 3D Cursor.
  7. Duplicate Bone.L and scale Bone.L.001 -1 on X (Bone.L.001 should now be aligned with the 'fake' half of the cube.
  8. Use 'Flip Names' on Bone.L.001. Observe that it is now named Bone.R.001
  9. In Object Mode Select the Cube, then the Armature and perform a Parent operation. Select 'Use Automatic Weights'
  10. Select the armature and set it to pose mode.
  11. Select the Cube and go to Weight Painting mode.
  12. Select Bone.L to see its weights. Observe that it is weighted for both sides of the cube. (see attached .blend file)

This is occurring because the .00x suffixes for duplicated bones are being retained after a Flip Names operation (see T51543). I understand that this is apparently 'intended functionality' but I hope you can see that completely nullifies the time saving aspect of Flip Names as the user now must manually delete the suffixes for duplicated bones in order to get proper automatic weights.

Details

Type
Bug
Joshua Leung (aligorith) triaged this task as "Confirmed" priority.Mon, Sep 11, 7:38 AM

Indeed, it seems that the new Flip Names behaviour is causing problems here, meaning that this is a duplicate of T52685

Joshua Leung (aligorith) closed this task as "Archived".Sat, Sep 16, 7:50 AM
Joshua Leung (aligorith) claimed this task.

Close as duplicate.