Cycles: Denoising generates artifact(s)
Open, NormalPublic

Description

System Information
Linux Ubuntu 16.04
Nvidia GeForce GTX 970

Blender Version
Broken: 2.79-RC2
Worked: not available (denoising is new)

Short description of error
When using denoising feature an artifact is generated. The object is a simple glass body. The denoising parameters are on defaults.
The scene gets rendered correctly without denoising (see images)

Exact steps for others to reproduce the error
Based on an attached .blend file with minimum amount of steps

without denoising

with denoising

red circle: here is the artifact

Details

Type
Bug

I could reproduce this on 2.79 RC2, but it works OK (no artifact with denoise on) using Blender 2.79.1 hash 11a9434 (Sun Sep 10 03:08:03 2017) from "Download Latest Builds".

Bastien Montagne (mont29) triaged this task as Normal priority.

@Lukas Stockner (lukasstockner97) I guess you'll know whether this was already fixed or not? If yes, can you please also check commit is in 2.79 branch? Thanks

Hi.
Maybe new Russian Roulette method helped here?
Just to mention just in case. If you increase Lamp size (1 for example), some weird things still happen in this scene using resent blender from buildbot:

Hi I was going to add a new bug but I suspect mine is similar - let me know if not and will create a new one

This is with 2.79 Nighty 2018-04-28, hash: 60f4cb24da7

I am on a MacBook Pro with Compute enabled on cpu and Radeon (if I enable the intel HD a service seems to crash in the background)

Simple scene with a cube and two lamps

Denoiser Off

Denoiser On

Denoiser On with Diffuse Direct turned off (which is the same obv.)

All other settings are default as far as I know.