Page MenuHome

Animated textures (like MP4) are not refreshing during playback or frame changing
Closed, ArchivedPublic

Description

System Information
Windows 10 x64 version 1703

Blender Version
Broken: 2.79 release

Short description of error
When I load an mp4 as a texture for a plane the texture won´t refresh unless I have the texture panel opened, and if I press playback in the timeline, it won´t refresh unless I do that with the keyboard while having the mouse over the textures panel

Exact steps for others to reproduce the error
1.- Import an mp4 as a texture for a plane, be sure to check auto-refresh
2.- scrub the timeline
3.- It doesn´t work
4.- open the texture panel
5.- scrub the timeline
6.- it does work
7.- press playback with the mouse
8.- It does not playback
9.- put the mouse over the texture panel
10.- play the scene with the keyboard (Atl+A)
11.- it refreshes
12.- Stop it
13.- press the OpenGL Render Active Viewport
14.- it does not refresh the texture either
15.- put the moouse over the texture panl and play the scene with the keyboard (Alt+A)
16.- it refreshes during the playback
17.- while playing press the OpenGL Render Active Viewport
18.- It does refresh the texture in the render

Details

Type
Bug

Event Timeline

Joshua Leung (aligorith) closed this task as Invalid.
Joshua Leung (aligorith) claimed this task.

In the Timeline, go to the "Playback" menu and enable the "Property Editors" checkbox.

Ok, this means that I don't have to have the mouse over the texture panel when I press playback, but IF i'm not in the texture panel, the texture won't play back, no matter what do I activate in the Playback menu...

And when you press the OpenGL render it does not refresh the texture during the render unless you were already in playback...

I think this is a valid bug, if you want I can fill in two different bugs without the part solved with the Playback menu, but it's a small part.

Juan Gea (juang3d) reopened this task as Open.Sep 15 2017, 10:05 AM

I promise I won't change the status of the task again if you say this is not valid and it has some correct workflow, but I was not sure if you were receiving the updates since it was tagged as invalid, so I re-enabled it.

Sergey Sharybin (sergey) closed this task as Archived.

OpenGL is having hard time with movies and image sequences because currently OpenGL materials does not have a proper image user to store/update frame for image access. This is a known TODO, and it'll be more efficient to address this in new viewport of Blender2.8.