Rigs GONE?! This is CRAZY!!
Closed, ArchivedPublic

Description

System Information
Operating system: any and graphics card: any

Blender Version
Broken: 2.79
Worked: all previous ones

Short description of error
As per the official docs:

When using the add-on Rigify, please note:  

Compatibility is broken for this release.  
There's no guarantee rigs created in previous Blender versions will work correctly.  
Rigs created in Blender 2.78 may not be compatible with 2.79.  
Rigs created in Blender 2.77 may still work.  
Save your work before attempting upgrading your rigs.

That's TOTALLY UNACCEPTABLE.

Exact steps for others to reproduce the error
Since I don't want to re-make ALL my meshes (NO. Really: NO).
I'll never install such a BUGGED version on my machine.
I'll stick on Blender 2.78c FOREVER.
Unfortunately, I won't get denoising.
But - you know what? - I strongly prefer my rigs!

Details

Type
Bug

I'm no longer a maintainer of Rigify, but I also found that note rather strange. I'm also pretty sure it's false, at least as stated.

I think what they *meant* is that the new Rigify won't be able to *generate* rigs from earlier *metarigs*. But actual rigs (the generated rigs) created with the old Rigify should continue to work, because they have no dependencies on the addon.

Can we get some clarification here? And if I am correct in my above assertions, can the release notes please be fixed? It's extremely misleading.

As an aside:
One of the design principles I adhered to when creating Rigify is that generated rigs should be completely independent of the addon. And for precisely this reason. Updating the addon should never break existing rigs--that would be a hazard for productions using Rigify.

thanks for your input, during the 2.78 build there was issue with rigify that was largely unnoticed, fixing this error broke some back compatibility.
You can also read the rigify docs, possibly legacy mode might help.
We now have a far better rigify system, built to last out the 2.79x.
Thanks.

@Nathan Vegdahl (cessen)
the issue was with blender ik/fk switch, which was broken during 2,78 due do blender code. fixing this meant that rigs created in 2.78 may not work with current rigify.

Hi Brendon,
Did you see my comment? I believe that the release notes are extremely misleading, and should be changed. I can file another issue if needed.

Oops, looks like we posted at the same time. Ha ha.

In any case, that doesn't have anything to do with updates to Rigify then, correct? In other words, changes to Rigify didn't break the rigs. Changes to Blender did. And presumably could break other rigs that were manually created but used similar code.

Agreed the release notes are a bit misleading on this point. I just dealt with T52747 yesterday, where it's probably not clear that the potential for rig breakage is not exclusive to Rigify, but rather may affect any rig that uses non-uniform IK scaling.

Paging the b.org release notes page maintainer: @Pablo Vazquez (venomgfx)

The new notes state that

Rig compatibility:

Changes to IK snapping may affect rigs that use non-uniform IK scaling. (rigs created in the 2.78 builds.) 

During the 2.78 series: IK snapping was partly broken.

This has been fixed for Blender 2.79
Rigs created in Blender 2.78 may not be compatible with 2.79.
Rigs created in Blender 2.77 may still work. 

When using the add-on Rigify, please note:

Compatibility is broken for this release. There's no guarantee rigs created in previous Blender versions will work correctly.
Rigs created in Blender 2.78 may not be compatible with 2.79.
Rigs created in Blender 2.77 may still work.
Save your work before attempting upgrading your rigs.

Does this mean that I should

1 - Reinstall Blender 2.77,  
2 - re-save every file and then
3 - I can migrate to version 2.79?!

How bad is that?!

This is indeed a case when an alleged "bug-fix" is SO MUCH LESS DESIRABLE
than the so-called bug itself.

Who wants a bug fix that generates more harm tha the alleged bug did?
Me, personally, I don't want this fix at all.

Therefore, I absolutely refuse installing version 2.79.

My only one regret will be: Denoising.

  • Filmic is available as an add-on. NO REGRET for not having it bundled.
  • Shadow catching... already done in the past. NO REGRET for not having it bundled.
  • PBR Shader ("Principled shader")... same as above.

700+ bugs fixed... If all the fixes introduce more hassle than benefits, NO THANKS!

Luca Crisi (BugFinder) reopened this task as Open.Sep 15 2017, 7:02 PM
LazyDodo (LazyDodo) closed this task as Archived.Sep 15 2017, 7:11 PM

While I understand your frustration, 2.78 was the 'broken' version, and as much as we'd like to go back in time and prevent the issue, we can't, nor is carrying the bug forward for future versions an acceptable strategy. Given this is not a bug and things are now working they way they should, I'm going to close the ticket. please do NOT triage your own tickets and leave that up the people staffing the bug tracker.

You may hopefully receed from your vision of the thing, undo this "bug-fix"
and therefore recover this disaster.
Because that's what it actually is, when called with its real name.

What was supposed to be a FIX is an even worse BUG, instead.
How to call that, if not an EPIC FAIL?!

Luca Crisi (BugFinder) reopened this task as Open.Sep 15 2017, 8:05 PM
LazyDodo (LazyDodo) closed this task as Archived.EditedSep 15 2017, 8:23 PM

I understand being told no is frustrating, you may vent all you want, with all the capitals and bold text you can muster, but i really have to ask you to stop re-opening this ticket.

@Brendon Murphy (meta-androcto)
Thanks for updating the notes! That's much clearer. I really appreciate it. :-)

You may hopefully receed from your vision of the thing, undo this "bug-fix"
AS SOON AS POSSIBLE and therefore recover this disaster (let's call things
with their real name).

What was supposed to be a FIX is an even worse BUG, instead.
How to call that, if not an EPIC FAIL?!

Now I should:

  • Install Blender 2.79 on a test machine
  • Open 350 blend files
  • Test which ones have been fucked-up by the new SHIT-RIGIFY

If they are, on the same machine

  • Uninstall Blender completely
  • Install Blender 2.77
  • Re-save the broken ones with Blender 2.77
  • Re-install Blender 2.79
  • Re-test if they are still fucked-up by the new SHIT RIGIFY and prey

... Really? Well, you must be totally insane.

@Luca Crisi (BugFinder)
hi, thanks for input.
Please do not come here yelling and screaming, thanks.
blender had a bug during the 2.78 series which needed fixing.
the results of this were possible breakages on rigs that use ik/fk snapping that were created during the 2.78 series.
not just rigify rigs, but any rigs.
I'm sorry to hear that you don;t like new rigify, but that's no reason blame them for an issue that was not in their control.
It took a rigify user some time to track down the cause of this bug and the rigify devs were just as affected as everyone else, with their own projects being made, in 2.78
The user who reported the bug was also affected.
so whilst this was good for no-one, we had to deal with it and move on with the knowledge that blender 2.79 is a long term build that needs to be as good as we can until 2.8 is stable.
please do not re-open tasks.
closing again.

@Joshua Leung (aligorith) wrote:
Paging the b.org release notes page maintainer: @Pablo Vazquez (venomgfx)

Thanks for the poke! Matched wiki/b.org compatibility warning notes.
https://www.blender.org/features/releases/2-79/#compatibility-warning

Now, rigs worked till version 2.78c.
Then someone put his dirty fingers on it, and ruined it.
Now it doesn't work anymore.

Meaning that it now breaks previous WORKING rigs.
And this is more than enough to call it a BUG.
And also a nasty one, indeed (Rigify has become Shittify).

I'll keep reopening it until someone reverts RIGIFY back to its WORKING state
once and for all.

After all, where should a bug complain be put, if not in a bug-report repository?
And why should it be closed and/or archived, if it does persist?

Best regards.

Luca Crisi (BugFinder) reopened this task as Open.Sep 17 2017, 9:28 AM

@Luca Crisi (BugFinder)
Please stop re-opening this task.
There is no bug here.
If you are unhappy with the changes made, so be it.
You can still use whichever version you were happy with and created your files with for any ongoing projects.
Please note that your activity here is inappropriate both with the content and with the re-opening of closed tasks.
Please cease activity in this task.
Closing.

What I did meanwhile:

  • I checked all the files in my working folder for the magic number:

BLENDER-v278
and saved the file list

  • I copied the last version of each of those files on a pendrive
  • Brought them on a PC where I previously updated Blender to version 2.79
  • Opened them to check out which one had an Armature and which of those rigs

was screwed up.

The good news is that I found a very few ones.

Now, hopefully, totally uninstalling Blender an then installing version 2.77 on
that PC in order to open and re-save the files will fix the issue.

Then (and only IF it does the job) I'd be able to migrate to version 2.79.

Luca Crisi (BugFinder) reopened this task as Open.Sep 17 2017, 2:13 PM

Luca: Your point was made, developers responded in a fair way. Now we close this.

Also closed topics can have discussions and get replies. It only means we don't publish it as an active open bug in Blender.

Note that we will disable your account if you keep behaving badly. This is a last official warning.

Ton Roosendaal (ton) closed this task as Archived.Sep 17 2017, 4:13 PM

Uh, I didn't know that I could reply even if the bug was closed.
I don't think I behaved badly. But I'm really upset.

Breaking the compatibility with what you have done till now
should never ever happen.

It's actually a major QUIRK.

As I said, the "fix" is worse than the "bug".