Page MenuHome

Zero size bone crashes blender when used as bendy bone handle
Closed, ArchivedPublic

Description

System Information
Win8.1x64, 3x gtx580

Blender Version
2.79

Short description of error
When coordinates of a head and tail of a bone used for bendy bone handle are the same blender crashes in pose/object modes.

Exact steps for others to reproduce the error

  • With open file, in the viewport, press Shift+S -> Selection to Cursor
  • Press tab to exit Edit Mode ->Crash

Details

Type
Bug

Event Timeline

Joshua Leung (aligorith) claimed this task.
Joshua Leung (aligorith) triaged this task as Normal priority.
Joshua Leung (aligorith) raised the priority of this task from Normal to Confirmed, Medium.Sep 25 2017, 3:00 AM

Confirmed.

This is probably caused by the first bone becoming zero-length, and thus being removed, but the bbone still refers to the newly removed bone.

Demeter Dzadik (Mets) raised the priority of this task from Confirmed, Medium to Needs Triage by Developer.

Can't reproduce on latest build. Can anyone else?

Philipp Oeser (lichtwerk) closed this task as Archived.

Also cannot reproduce this one in current master.
2.79 was mentioned here, but since we are not fixing bugs in 2.79 anymore and in 2.81 this seems to be working fine: will close...

@Konstantins Visnevskis (kivig): feel free to reopen if issues persist in 2.8...