Page MenuHome

Key switch on QWERTZ (de) keyboard
Closed, InvalidPublic

Description

System Information
OS: Win7, x64, Build 7601
GPU: Radeon R9 290X

Blender Version
Broken: 2.79, 5bd8ac9, 2017-09-11 10:43
Worked: 2.78c

Short description of error
There seems to be a bug where it either uses the wrong keys on my QWERTZ keyboard, or the highlighted directional lines are bugged.

I wanted to scale a mesh and pressed S and then Shift + Y so that I can edit everything but the Y axis. It did scale the Y axis and did not scale the Z axis.
Same thing with the Z axis. S, Shift + Z scales the Z and X axis, but not the Y axis.

Same applies to mesh moving (G).
Both apply to the object mode as well as edit mode.

I checked my Computers Region and language settings. There is no entry for a keyboard other than my QWERTZ keyboard with german layout. So I can not switch with any key combination to a different keyboard language.
I have worked with the same blender version on my Laptop as well and I didn't get the same bug there yet.

Exact steps for others to reproduce the error
It seems to be random to me, so there is no step-by-step way that I could tell or any bugged blender file I could upload.
In one moment it works. The next edit step has the wrong keyboard. After a few minutes, after I adjusted the usage to the wrong button use, it switches again. There is nothing I can think of that could cause that. The weird thing is that I didn't restart blender in the mean time.

Images

I have installed the screencast script and will look out what blender says about the used button when the bug reoccurs.

Details

Type
Bug

Event Timeline

forceengine added a comment.EditedOct 14 2017, 12:58 AM

Same for Ctrl + z. That does not work. I have to use Ctrl + Y.

Sounds like it's reading it as a QWERTY keyboard.
If it was a bug for German keyboards I'm sure we would have heard about it by now.
Have you tried another computer or another keyboard on that computer?

Bastien Montagne (mont29) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.Oct 14 2017, 9:40 AM

Please follow our submission template and guidelines, also read these tips about bug reports, and make a complete, valid bug report, with required info, precise description of the issue, precise steps to reproduce it, small and simple .blend and/or other files to do so if needed, etc.

We do not even know which OS you are using!

forceengine updated the task description. (Show Details)Oct 15 2017, 10:11 PM
forceengine added a comment.EditedOct 15 2017, 10:39 PM

Update:
You can switch between the keyboard layout in Windows 7 pretty easy by using Alt (left) + Shift.
<s>If you do so, z and y will switch (among a few other keys), <u>however</u>: This does not seem to effect blender. Even when the keyboard layout is switched, blender still sees Z as Z and Y as Y - same applies to Shift + Z/Y.</s>

Ok, I think I got it.
Short story: It is not a bug as such.

Long story: It seems to be a bad interaction on the Windows<->blender side (or maybe an intentional Windows "feature"). If you press Alt + Shift outside (!) of blender's window, it will not switch the keyboard keys for blender. If you press it inside of blender's window (so blender is the active / top window), it will switch the keyboard layout for blender. It seems that this change only effects the window in which you have pressed Alt + Shift and is only active as long as the window is open. Once you closed the window, the change is reverted. If the layout is switched, there is no indication (visual or audio) for that. Since Alt + Shift is used in some keybindings in blender, it explains why it seemed so random. If you press any further button (eg. Alt + Shift + Y) there is no keyboard layout change, even the button combination may don't even exist.

So: No bug, but maybe worth a little "You just switched the keyboard layout! \nPress Alt + Shift to revert it" note

forceengine updated the task description. (Show Details)Oct 17 2017, 5:52 PM
Joel Godin (FloridaJo) closed this task as Invalid.Oct 19 2017, 5:34 AM
Joel Godin (FloridaJo) claimed this task.