Page MenuHome

Particle instance modifier omits mesh edges
Closed, ResolvedPublic

Description

System Information
Win 8.1x64, 3x gtx580

Blender Version
2.79

Short description of error
Particle instance modifier, when creating instances transfers mesh vertices and polygons but not edges.

Exact steps for others to reproduce the error

  • Switch on/off the particle instance modifier.
  • Instanced meshes lose edges.

Details

Type
Bug

Event Timeline

ronan ducluzeau (zeauro) triaged this task as Confirmed, Medium priority.

Particle Instance modifier was present in 2.4x.
It is older than skin or screw modifiers.

For attached .blend, simple workaround is to change order in modifiers stack.
Limitation to keep Generate modifiers before Particle Instance modifier can be added to manual.
It is not currently documented.

But it could be interesting to support this when we want to merge result of particle instance modifier with a mirror or an array of itself.


Merging edges should give a different effect.

Changing the order eliminates the purpose. Which is to create impression of particles being bent differently with a controlled degree of cross-neighbor relatedness (think flower petals, mosses - lots of small scale repetitive structures). Because if the deformation texture scale is large enough for that to work (affecting particle mesh as whole, not just shifting separate vertices randomly), it begins also affecting particles as a whole, not individually.
A tested alternative for such cases is creating individual objects instead of particles with noise*location based driver deformation modifiers, however that has to deal with mass application of drivers, them using "self", etc, grinding performance of anything but unique cases to a halt.
A theoretical work-around would be having custom object hair PS, but objects seem to replace hair, not following their shape.

You can use Particle Instance with hair. But workflow is strict and ask an object oriented to its Y axis.
Then, you can use several objects and PS to add diversity into shapes.

Thanks, I'm aware of that, the diversity itself is achievable quite easily. The goal was in interpolation of that diversity (like "clumping" in hair) and at moment that takes considerable amounts of magic, that instance modifier being compatible with skin modifier would alleviate in some cases. Sure, it may not be worth the time investment if the PS system will be rebuilt, but it's out of my competence to judge.

Hi everyone, I know this report is quite old, but I think this is fixed in master by a change I made recently (see rB288d7794d4c6836e1322d5ed943c4fbd4b0b0e54)?

@Konstantins Visnevskis (kivig) : can you confirm, so we can close this?

Tested - looks fixed. But now another problem (maybe unrelated) showed up (it isn't there in 2.79)

  • Subsurfaced edges maintain vertex radius only in old vertices. New (interpolated) vertices have vertex radius set to 0, which can be visualized by applying skin modifier to a subsurfaced edge.
Philipp Oeser (lichtwerk) closed this task as Resolved.Dec 12 2018, 9:45 AM
Philipp Oeser (lichtwerk) claimed this task.

@Konstantins Visnevskis (kivig): thx for getting back, will close this report then.

reg. subsurf: mind opening a separate report for this? (since this is a different issue...)