The constrain axis manipulator often fails to function when the 3d view is maximised
Open, Needs TriagePublic

Description

Blender Bugs

System Information
OSX 10.13
NVIDIA GeForce GT 755M 1 GB

Blender Version
Broken: 2.79
Worked: Never? spotted it about 7 years ago, but only just around to filing this!

Short description of error
The constrain axis manipulator often fails to function when the 3d view is maximised

Exact steps for others to reproduce the error

  1. Use Shift + Spacebar to take the 3d View into full screen
  2. Try to constrain the axis of an object's movement by dragging on one of the manipulator axis (red, blue or green arrows)
  3. You should find that the object's translation is not constrained as you would expect?
  4. …oh…works fine at the mo? I started this report yesterday and quit it, because I couldn’t reproduce….but the next morning I can!
  5. So, I am still not exactly sure ‘how’ to faithfully reproduce, but I definitely have again…

I think this is the reason I have never fully reported it, because I can’t figure out the exact cause. However, these things I know for sure….

3d View must be maximised (Shift+Spacebar)
Must be in Perspective view! Flipping back between Ortho and Perspective (Numpad 5) you can see that the Axis Constraint works fine in Ortho, but not in Perspective.

Once the bug is ‘found’, it is persistent…
You can ShitSpacebar back to normal UI, all will work, but if you immediately ShiftSpacebar back to maximised, the constraint will fail again.

Also, with regard to Blender version and operating system, I have noticed this bug for many, many years on multiple computers on both PC and Mac computers.
Hope you can find it! Will report back if I figure out the exact reproduction steps…
I currently have the bug in Edit Mode, but it can definitely happen in Object Mode too.
Cheers
Wayne

Details

Type
Bug

The fact that problem did not happen one day but was present next day makes me think that it might be relative to preferences or addons.

Next time, it happens try to save .blend file and to reload factory settings.

Currently, I did not succeed to reproduce on linux.

Bastien Montagne (mont29) triaged this task as Incomplete priority.Oct 31 2017, 3:10 PM

Am sorry, but we need a valid, stable way to reproduce an issue to investigate it. Cannot reproduce it here either (debian testing system with GTX850m and current NVidia drivers), this could be caused by a lot of stuff (buggy drivers, buggy hardware, …). First to try I’d say is to see if you can reproduce it on other systems (ideally same ones, or close to).

Ahah! I've found the cause!! So, happened again this morning, and I was almost considering making a video to show you what I meant, but while playing around with the 'bug' I finally realised that some objects would still constrain - then it dawned on me that those objects were further away - so, I zoomed out to move my problem object further away, and, lo and behold - axis constrain! So, I'm supposing it's a clipping plane thing? If the object is too close to the viewer, it is out of some operational clipping bounds and therefor doesn't get the constrain code?
Would you mind trying to recreate yourself? I am able to 'fix' the problem when it happens (by zooming out), but wonder if you are able to 'create' the problem by zooming in?
Thanks
Wayne

Could not reproduce here on linux. Could be OS specific. File with bug happening for you would be needed.

Ubuntu 16.04.3 LTS
Blender 2.79 build master 66a6d16
NVIDIA 1080 driver 384.90

Fable Fox (fablefox) closed this task as Invalid.Sat, Nov 18, 3:08 PM
Fable Fox (fablefox) claimed this task.

Thanks for the report but it would be helpful if you add a blend-file to the report that demonstrates the issue at hand.

Since last asking for information it has been 7 or more days, due to the policy of our bug tracker we will have to archive the report until the requested information is given.

Wayne Smith (slowboy) reopened this task as Open.EditedMon, Nov 20, 1:32 PM


Very sorry for the late reply, guys - I somehow missed the request for an example file.
So, I've got one now, and reopened the bug, hope that's ok?

Within the file, select any of the multiple objects in the viewport and move it using an axis constraint - you will find that the axis constraints function.
Now, zoom in to any object, with numpad period, or just zoom so that an object fills the viewport, and try using an axis constraint again - for me, the axis constraint disappears and the object's movement is not constrained at all.
Would be interested to see if anyone else can reproduce this?
Thanks
Wayne

Vuk Gardašević (lijenstina) raised the priority of this task from Incomplete to Needs Triage.Tue, Nov 28, 7:16 AM

Some additional information was provided.

Marking as Needs Triage.