Page MenuHome

navMesh.replaceMesh('mesh',1,1) + navMesh.rebuild() does not use new meshProxy
Closed, ArchivedPublic

Description

System Information
all -

Blender Version
always broken

Short description of error
navMesh.replaceMesh('mesh',1,1) + navMesh.rebuild() does not use new meshProxy

Exact steps for others to reproduce the error
press p

press space to run

python
import bge


def main():

    cont = bge.logic.getCurrentController()
    own = cont.owner
    
    own.replaceMesh('m2',1,1)
        
    
    print('editing mesh')
    
    start = own.scene.objects['Agent'].worldPosition
    target = own.scene.objects['Target'].worldPosition
    
    path = own.findPath(start,target)
    
    for p in range(len(path)):
        if p!=0:
            point1 = path[p]
            point2 = path[p-1]
            bge.render.drawLine(point1,point2,(1,0,0))
        
        
    own.rebuild()
    print('rebuilt')
main()

if mesh were updated, and navmesh rebuilt, agent would reach object 'target'

Details

Type
Bug

Event Timeline

Aaron Carlisle (Blendify) closed this task as Archived.

This task is being closed because the BGE has been removed in Blender 2.8.