Page MenuHome

When with HSV Color editor adding 1 or 0 value, it resets the saturation also.
Closed, ArchivedPublic

Description

Blender Version
2.79

Short description of error
This is kind of working already correctly, but it would be more user-friendly if the colour editor would virtually keep the saturation value in the memory at least to the moment when you release the mouse. Now you can easily accidentally reset the saturation value even when you are for real trying to find something that is graphically pleasing your eye.

Exact steps for others to reproduce the error
Play with HSV colours and you will see this.

Details

Type
Bug

Event Timeline

ronan ducluzeau (zeauro) closed this task as Archived.
ronan ducluzeau (zeauro) claimed this task.

It is a design issue relative to color picker.
User have to deal with huge amount of colors. Keeping in memory many HSV combinations that are resulting into a pure black is probably not the best way to keep .blend files light.
Actually, in most cases, you can use a Combine HSV node that will treat values separately.

While its disputable how this should work, it is behaving as intended and not an error in the code.

While we love to hear these ideas, this is not the right place for them. This website is mainly used to track bug reports and not feature requests. But luckly, there are some other nice solutions you can take, so please use one of the other forms of communication listed below:

https://rightclickselect.com/
Fun board mailing list: https://lists.blender.org/mailman/listinfo/bf-funboard