Page MenuHome

middle mouse button orbit function not working
Closed, ResolvedPublic

Description

on MacBook Pro macOS High Sierra 10.13.1
On Toshiba Sattelite pro Windows 7 x64

Blender Version
2.79

The middle mouse button orbit function stopped working. Tried re installing Blender both on Mac and Toshiba laptop to no avail.

Exact steps for others to reproduce the error
Based on a (as simple as possible) attached .blend file with minimum amount of steps

Details

Type
Bug

Event Timeline

Are you using a 3 button mouse with your laptop or are you talking about the emulation made for trackpad ?

When people are installing a new release of Blender, they are expecting everything to work and often forget that they had changed user preferences in the previous version.

Please
If you are using trackpad, can you confirm that you have checked user preferences options ?
If you are using a 3 button mouse or a 3D mouse, can you precise your device model and check if its driver is up-to-date ?

Yes, I am using a three mouse button. I have tried all the mice I have laying around even my ancient Logitech with a cable.
I have checked the settings.
The strange thing is that it stopped working gradually. Initially it was ok, working fine then it began to stick, ie: I needed to click the roller button a couple of times for the tool to get activated then it stopped completely. Both on my MacBook Pro and Toshiba Sattelite !!! Drivers are ok.

Have you tried reverting to factory settings (don't worry, it won't save that way unless you tell it to)
and disable any addons you enabled?

Actually no. I'll try that now. Thanx!

This comment was removed by Panos Trimis (PP369).

Problem solved. It was not a Blender issue. The roller switch on all my mice was dirty!!! Thaks for your responce guys!

Panos Trimis (PP369) closed this task as Resolved.Nov 26 2017, 2:27 PM

The comment about trying all the mice laying around can throw one off.