Page MenuHome

Bevel operator do not confirm on release nor with spacebar like others
Closed, ResolvedPublic

Description

System Information
win 10

Blender Version
2.79

Short description of error

Most blender operators are executed when LMB is pressed or released(always like inset or if 'Release confirms' option is selected in user preferences like transform).
Also, most can be executed by pressing spacebar instead of LMB.(like extrude)

That is not the case with bevel operator though.

(also it looks like inset operator cannot be executed with spacebar as well, it do work on LMB release though)

Exact steps for others to reproduce the error

Use bevel operator then try to confirm it with spacebar instead of LMB

Details

Type
Bug

Event Timeline

Try a later version from build bot. Bugs have recently been squashed on these.

on 2.79.1 bb30ce0

looks like other problems connected to properties where fixed. I didn't notice that before, that's actually great.
But confirming is still not consistent, now for both inset and bevel.

all other modal operators are accepted by pressing(only PRESS by default) LMB or pressing spacebar, except those two.
also, if 'Release confirms' option is enabled other operators ( like scale or transform) are executed if LMB is pressed or released. except those two (inset and bevel).

for 'Release confirms' I am thinking about that option

One more thing I noticed, is that transform operator has its own modal hotkey map. Because of that a lot of things can be set by the user, it looks like 'Release confirms' is some old option that is not needed in case of transform operator at all since that can be changed by a user in another way.

any other modal operators do not have that modal map though, it would be superior to have that.
That way user can add spacebar to hotkeys by himself.

I am happy to change the code for Bevel and Inset to allow spacebar for confirm. Just wanted to check with someone else (Campbell?) that this is indeed a UI pattern that Blender is intended to have.

Howard Trickey (howardt) closed this task as Resolved.Mar 21 2019, 12:00 PM

Closing this now that Bevel has a user editable keymap, so users can map spacebar to confirm if that's what they want.