Crash opening file with linked particles
Closed, ResolvedPublic

Description

Blender Version

Blender 2.8 after duplicator visibility commit.

Short description of error

Crash happens in versioning code when opening file with linked particle systems.

Exact steps for others to reproduce the error

Get this two files, open scene.blend.

This is because versioning does access psys->part->foo from a do_version_280(). This do-version is called after direct linking only, meaning, pointers to library data are NOT valid. Such versioning code is to be done in do_versions_after_linking().

Details

Type
Bug
Sergey Sharybin (sergey) triaged this task as Unbreak Now! priority.

@Dalai Felinto (dfelinto) , have a great pre-holiday bugfixing :)

Dalai Felinto (dfelinto) closed this task as Resolved.Jan 25 2018, 2:05 PM

Fixed on fec3be6b5455 - I forgot to write "Fix" in the commit message.