Page MenuHome

Surface Book 2 pen pressure sensitivity issue
Closed, ArchivedPublic

Description

System Information
Windows 10
NVIDIA GeForce GTX 1060 discrete GPU w/6GB GDDR5 graphics memory

Blender Version
2.79 5bd8ac9

Short description of error

Exact steps for others to reproduce the error
Pen pressure sensitivity doesn't seem to work with Blender. I watched several video tutorials and tried multiple settings but can't make it work. I'm wondering if it is a driver issue?

Thanks,

Christian

Details

Type
Bug

Event Timeline

Joshua Leung (aligorith) triaged this task as Needs Information from User priority.
  • Does pen pressure sensitivity work in any other apps (e.g. Krita, Gimp, etc.)?
  • Is this limited to any specific part of Blender (e.g. Grease Pencil, Sculpt, or Image/Texture Paint)?
  • Have you tried searching for whther anyone else has been encountering pressure sensitivity issues with the Surface Book? At least for earlier versions of these, there have been cases where there have been problems using them with various apps.

I'll mark this as incomplete / a hardware-specific issue for now. Until another dev with this hardware can investigate (or more info about possible compatability issues/fixes with these devices come to light), there's not that much we can specifically do about this.

Thanks for looking into this. I'll add some more details to try and answer the questions above.

  • Pressure sensitivity works with most other apps: Auto Desk Sketch, Clip Studio Paint, Fresh Paint etc. Can't get it to work with Gimp though.
  • Pressure sensitivity seems to not work across all of Blender, at least Grease Pencil and Sculpt
  • I've done several web searches and can't find anything regarding the Surface Book 2. It's a very new device though. Lot's of stuff on Wacom tablets but the pen settings seem a bit locked down on my device as compared to Wacom.

@Christian Hoffman (Dramock) : is this still relevant? Has above link solved this?

Philipp Oeser (lichtwerk) closed this task as Archived.May 1 2018, 9:26 AM
Philipp Oeser (lichtwerk) claimed this task.

Since last asking for information it has been 7 or more days, due to the policy of our bug tracker we will have to archive the report until the requested information is given.