Page MenuHome

Denoiser produces artefacts depending on radius
Closed, ArchivedPublic

Description

System Information

  • Windows 10 Pro
  • GeForce GTX 1080Ti

Blender Version
2.79 5bd8ac9

Short description of error
I worked some weeks on this project here: http://bit.ly/2FKTU0p

While the development I made interesting experience with the denoiser. Below you see an example what happen, when the denoiser is used with different values. What I do not understand are some points.

Why is the denoiser producing artefacts when using bump textures? My experience with diffuse and regular textures without any bumpmaps are well and mostly without any artefacts. As soon as bump maps or normal map informations are added, blender produces ugly artefacts like you see in my example below. It could be just a feeling, but I think bump maps and denoiser are not good friends...

Here are some settings with an image of a part of my scene to compare what happen. My official settings I am using are on the left hand in the shot.
The lower the radius the more splotches appear. They look like photon spots but are coming from the denoiser only. I've rendered the part with a very high resolution without denoiser to see if there are any photons visible, but all looks well.

Basically the smaller the radius in my experience the more splotches appear. And you can not improve it by experimenting with the options. Of course I get more details, when I use a smaller radius, but the artefacts overweight. So in my case I decided to use the highest radius, to get a smoother result. But even there are some splotches.

Is the denoiser still in development and can I expect some better results in the future?

Thank you
Chris

Details

Type
Bug

Event Timeline

Philipp Oeser (lichtwerk) triaged this task as Needs Information from User priority.

From a quick glance I would assume that this is more or less expected behaviour, but it is hard to judge without having a look at the actual .blend file.

  • afaik using bumpmaps makes it harder to denoise because lighting conditions actually change because of the bump (without knowing the internals of the denoiser it makes sense that a surface with a very uniform normal is easier to denoise)
  • in your example you are not only changing the radius, but also other parameters (which makes it even harder to judge)

Marking as incomplete until we can have a look at the actal .blend file
Assigning @Lukas Stockner (lukasstockner97) to share his wisdom here...

Brecht Van Lommel (brecht) closed this task as Archived.

The denoiser can always be improved, but there's nog bugs here.

As @Philipp Oeser (lichtwerk) says bump maps making it harder to do denoising, because neighboring pixels will have different lighting and there's less information to share. Denoising algorithms in general will convert high frequency noise to low frequency noise (splotches).

Thank you for your answer.

No problem. I prepared a reduced version of my scene for testing.
The file contains all needed textures too.

There is a render border I added, to give you the possibility to see the area I used in my tests.

Additionally I have prepared some new renders to show what happen using different settings. In this case I just altered just the radius.

But there are two more examples where I have set a sample rate of 10.000 samples. This is something I normally would never do... because of to much render time and what makes no sense in most cases. But for testing it is really interesting to see what happen. Compare the radius of 8 in 1.200 samples. There are less artefacts at 10.000, but very expensive...

My wish would be to kow sometime the denoiser splotches disappear, that makes a flat texture area like the wall looking like a "ugly jpeg".

Here ist the scene for you:

An here the new render results to compare:

Hi Brecht. Thank you for your answer.
I haven't seen your post before I posted here.

A general question: Should I better post bugs only and not this mix of "feature request" and "experience"... ?
Sorry then.

Well, normally bugs only. Though this could have been a bug, it's hard to know these things without being familiar with underlying algorithms. It doesn't harm to report things just in case.