Page MenuHome

Video Sound Crash 2.78c and 2.79
Closed, DuplicatePublic

Description

System Information
linux Linux guu-PC-n960 4.4.0-93-generic #116-Ubuntu SMP Fri Aug 11 21:17:51 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
Elementary os latest
with nvidia N960 Graphic Card

Blender Version
Broken: 2.78c-2.79
Worked: (optional)

Short description of error
Everytime add a movie(mp4 format) in Video Editing ,then select the sound part of the video in Video Sequence Editor by right click
In the right panel , there is a Sound section under Edit Strip
click the X button in the First Line , then blender crashed with below infos outputed:

Writing: /tmp/blender.crash.txt
Segmentation fault (core dumped)

here is the blender.crash.txt

# Blender 2.79 (sub 0), Commit date: 2017-09-11 10:43, Hash 5bd8ac9abfa
bpy.ops.sequencer.movie_strip_add(filepath="/home/guu/Videos/Crystal_DanYu_Made/VID_20180109_110249.mp4", files=[{"name":"VID_20180109_110249.mp4", "name":"VID_20180109_110249.mp4"}], relative_path=True, show_multiview=False, frame_start=1, channel=1)  # Operator  
bpy.ops.sequencer.select(extend=False, linked_handle=False, left_right='NONE', linked_time=False)  # Operator
bpy.ops.sequencer.select(extend=False, linked_handle=False, left_right='NONE', linked_time=False)  # Operator
bpy.ops.sequencer.select(extend=False, linked_handle=False, left_right='NONE', linked_time=False)  # Operator

# backtrace
blender(BLI_system_backtrace+0x20) [0x1a6c8e0]
blender() [0x107a525]
/lib/x86_64-linux-gnu/libc.so.6(+0x354b0) [0x7fc5e1d754b0]
blender(BKE_sound_update_scene_sound+0) [0x18a3e10]
blender() [0x19c32f4]
blender() [0x1904592]
blender() [0x1288ea1]
blender() [0x125ecb6]
blender() [0x126f269]
blender() [0x108373c]
blender() [0x1083ba8]
blender(wm_event_do_handlers+0x1d4) [0x1083eb4]
blender(WM_main+0x18) [0x107b108]
blender(main+0x3f8) [0x1018bd8]
/lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf0) [0x7fc5e1d60830]
blender() [0x107747e]

Details

Type
Bug

Event Timeline

Philipp Oeser (lichtwerk) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.Jan 24 2018, 4:17 PM

This has most likely been fixed already (I could reproduce in 2.79 but not in current master)
could you try a build from here and try again?
If that doesnt solve the problem, please upload the video file here...

Marking as incomplete for now...

Joshua Leung (aligorith) closed this task as Resolved.Jan 25 2018, 3:46 AM
Joshua Leung (aligorith) claimed this task.

This is a duplicate of T52890, which has already been fixed in master, and will be included in the 2.79a release