Page MenuHome

Audio keeps playing even with negative frames
Closed, ArchivedPublic

Description

System Information
Windows 7 Ultimate, 64-bit, 32GB, 5960x, Nvidia Quadro FX 1800 (Primary) & GeForce 9800 GTX+ (Secondary)
Graphics Tablet: Wacom Bamboo Model: CTF-430 Driver Version 5.2.4-5

Official release(s) unless specified:
Broken: 2.79

Short description of error
When 'Allow Negative Frames' is enabled in user preferences and No Sync is selected, audio playback happens in negative frames.
If you can't play the video in your web browser, right-click the video --> copy link address (or equivalent) and play it in a media player like VLC.


The sound track is Big Buck Bunny (didn't want to upload 500mb)

Details

Type
Bug

Event Timeline

Philipp Oeser (lichtwerk) triaged this task as Confirmed, Medium priority.Jan 24 2018, 7:33 PM
Joerg Mueller (nexyon) closed this task as Archived.Jan 31 2018, 12:47 PM

Hi, thanks for the report. This is a known problem - audaspace doesn't work with negative timings. The reason for this is that blender itself wasn't really designed to work with audio - to overcome some of these problems, I had to make some design decisions that ended in not supporting negative timings. The alternative would have been to not support animation (of volume, pitch, etc.), which is definitely the worse alternative. We could at least document somewhere that negative timings don't work with audio?