Drivers don't read Cycles Material nodes
Closed, ArchivedPublic

Description

System Information
Windows 8.1, nvidia Geforce 920M

Blender Version
Broken: (2.79, 5bd8ac9)

Short description of error
Drivers don't work when the input is from the cycles material node editor

Exact steps for others to reproduce the error
Add a cycles material, create any driver that takes input from any node variable within that material.


Attached example is attempting to control ScaleX using the variable input node.

Details

Type
Bug
Sergey Sharybin (sergey) closed this task as Archived.Feb 5 2018, 2:44 PM
Sergey Sharybin (sergey) claimed this task.

Material owns it's node tree, and the only "standalone" node trees you will see will come from node groups. So for your case you need to read from material datablock, using it's node_tree in RNA path.

Thanks for the report, but don't see bug here.

It seems like it is another bug, Blender doesn't save the path I specified here using "Add driver from target"

if that's another bug make a new report, with all the steps and demo file needed to reproduce it.

Alright, but what is the full correct RNA path that I should use to make the "Driver source" directly control "ScaleX"?

Here is a file for you:

Some notes:

  • This setup only works with new dependency graph.
  • It is possible that we are still missing some depsgraph updates on changes, so if something doesn't work for you, try saving and reload file and see if that fixes the issue. If that solves the issue, make a report about depsgraph missing updates.

Looks like that's the issue. Alright, I'll make a report then. Thanks.