Page MenuHome

Sequencer Scene preivew Color Management is broken
Closed, ResolvedPublic

Description

Blender 2.8
Failling : dff7f55cd069a15493db00aef8f28f4f3be24b8f
Working : unknown

Final display space is kind of broken for the scene preview strip.

Draw manager is outputing linear color into a byte buffer (could be float buffer if we want).
This byte buffer has the color management of the sequencer scene applied to it.

So maybe it would be a good idea to just output the byte buffer to the right display space? or keep a linear buffer and color manage in sequencer?
I don't know which color space should be use in this case, the scene that contains the sequencer or the scene of the strip?

This is tricky to debug because of this bug T54437

Details

Type
Bug

Event Timeline

Clément Foucault (fclem) triaged this task as Confirmed, Medium priority.

Byte buffer is supposed to be in display space, which is sRGB for current OpenGL in master. If you want to output linear space, do so to the float buffer. If you want to keep using byte buffer, apply OCIO GLSL on it.

This is nothing i can fix here, you're violating the existing design.

@Jeroen Bakker (jbakker), can you check if is fixed or needs additional work? This is quite an old report.

Jeroen Bakker (jbakker) closed this task as Resolved.Jun 7 2019, 8:52 AM

Solved with recent changes.