Page MenuHome

Uniform scale using Scale 3D manipulator is extremely sensitive
Closed, ArchivedPublic

Description

System Information
Windows 10, GTX1080Ti

Blender Version
Broken: 2.79 and 2.8
Worked: never

Short description of error
Scaling objects or mesh elements uniformly using a white circle on Scale 3Dmanipulator is extremely sensitive. Blender by design sets scaling sensitivity based on mouse cursor distance from the active pivot point. The problem is that 3D manipulator is always present exactly where the pivot point is, and that the central white circle responsible for uniform scaling is always in the center of the manipulator, in a very close proximity to a pivot point. Therefore, any attempt to use 3D manipulator for uniform scaling of an object or its element will always result in excessively sensitive scaling, as the cursor will always be very close to the pivot point when uniform scale action begins.

A simple, quick fix would be to enforce "precise" mode (what happens when you hold down Shift key) as initial state whenever 3D manipulator uniform scale is triggered.

This issue is also present in Blender 2.8, which already overhauls the 3D manipulator functionality, so it would be appropriate to include this fix as a part of 3D manipulator improvement initiative for 2.8 project.

Details

Type
Bug

Event Timeline

Guess this wont count as a bug per se (even though this could possibly be improved upon)
@Julian Eisel (Severin) : do you have an idea up your sleeve?

Well, the current state is so sensitive that you are literally not able to scale a cube to a desired size (especially when scaling down), because you are limited to a pixel density of your screen. It is so sensitive that moving a mouse cursor just one pixel on a 1920x1200 screen will scale the cube by a quite significant increment. I think that not being able to effectively scale a scene objects using a 3D manipulator fits into a definition of a bug.

Attached video example below:
https://youtu.be/Z162Mb-ST9M

Philipp Oeser (lichtwerk) triaged this task as Normal priority.

Still dont think this is a bug (as this is working as designed), but I feel your pain and leave this open so it doesnt get lost..., assigning @Julian Eisel (Severin) here to have a final word.

Philipp Oeser (lichtwerk) closed this task as Archived.Apr 25 2018, 6:25 PM

Just found out that in 2.8 this issue is already adressed (you can click anywhere, not just the circle), see comment in T54661 also.
So I guess this can be closed as "wont fix in 2.79, done in 2.8"

Just found out that in 2.8 this issue is already adressed (you can click anywhere, not just the circle), see comment in T54661 also.
So I guess this can be closed as "wont fix in 2.79, done in 2.8"

I am honestly not sure about this being a solution. In my custom keymap, dragging anywhere with LMB will trigger box selection, like it does in any other software or OS. If 2.8 reserves dragging primary mouse button anywhere in the viewport for uniform gizmo transform, then that will mean such keyboard mappings won't work anymore, or uniform scaling will stop working when input mapping is customized.

Furthermore, if Blender 2.8 comes with overhaul of input mapping down the road, I'd likely expect that it will be preferable to have box selection on dragging of primary mouse button, which will interfere with this solution.

@Ludvik Koutny (rawalanche) : have a look in T54582, this only comes into play, when you have the scale tool active

@Ludvik Koutny (rawalanche) : have a look in T54582, this only comes into play, when you have the scale tool active

I am sorry, but I am still confused. This would mean that to perform selections, I always need to deactivate active transform tool first. This would add one step to do prior every selection user wants to perform after using a transform tool. That is very cumbersome compared to pretty much any other 3D software with manipulators out there.

To clarify:
If i wanted to let's say transform a few objects in the viewport around, either doing uniform scale or screen space translate:

Current state:
1, Select objects
2, Transform
3, Select another set of objects
4, Transform

Proposed state:
1, Select objects
2, Enable transform gizmo
3, Transform
4, Disable transform gizmo
5, Select another set of objects
6, Enable transform gizmo
7, Transform

Scale speed is dependent on how close you click to the object you want to scale.
I too was having an issue with this until a bit of searching.