Page MenuHome

The World's horizon color doesn't work in Eevee with NVIDIA GPU, but it works with Integrated GPU
Closed, ArchivedPublic

Description

System Information
Windows 10 Pro 64-bit
NVIDIA GPU: NVIDIA GeForce 840M
Integrated GPU: Intel(R) HD Graphics 4600

Blender Version
Broken: Blender v2.80.5 (unstable 3/29/2018)

Short description of error
The World's horizon color doesn't work in Eevee with NVIDIA GPU, but it works with Integrated GPU.

Exact steps for others to reproduce the error

  1. Open NVIDIA Control Panel then keep the "Preferred graphics processor" to it's default setting (Auto-select), the NVIDIA GPU will be used by Blender in that case.
  2. Open Blender v2.80.5 to load the Start-Up File (Ctrl N), or restart Blender if it was already opened.
  3. Go to Properties area > World > Change the Color to green (G: 1.000).
  4. Now you see that the horizon green color doesn't affect to the Default Cube, it should be green.

Here is the .blend file, but don't forget to open it with Blender 2.8:

─ Eevee - NVIDIA GPU:


─ Eevee - Integrated GPU:
I didn't uplade the image because it's almost similar to the Cycles render result below. If you switch to Integrated GPU in NVIDIA Control Panel, then you may forget to restore the settings.

─ Cycles:

Details

Type
Bug

Event Timeline

Philipp Oeser (lichtwerk) closed this task as Archived.
Philipp Oeser (lichtwerk) claimed this task.

Thanx for your report.
It is working for me (with a 970m on linux with 390.42 drivers), maybe try different driver versions?

Anyways, it is still in early 2.80 stages and it was decided to limit bug reports to module team members for the time being.

Archiving for now...