Page MenuHome

Measureit 1.7.0 in Blender2.79b not shown when in "/" (local) mode
Closed, ResolvedPublic

Description

in version 2.79b,
addon measure it (V 1.7.0) for linux .. ?...
doesnt show (appear) anymore when using the "/" = LOCAL switch mode to show only selected meshes.
also i get back old files .. and compare by ok non-ok then try compare for the last file which was "measureit_main.py"
then i just modify back some lines...

in file joined:
(the green ones replaced by the new lines ("and" is ok) - then the blue lines on right is the new file where not included in old files
here then i cant do anymore correction

cheers !
not seen anything about that... so i put that here ...

author: "Antonio Vazquez (antonioya)"

Event Timeline

Which version of MeasureIt? I can't reproduce the bug with MeasureIt 1.7.0 (included with 2.79b). For me the measurements show in both "Local" and "Global" modes (what "Numpad /" toggles).

Philipp Oeser (lichtwerk) triaged this task as Needs Information from User priority.

I made a change here in rBAdc6704ab4 but also cannot reproduce, could you provide a simple .blend file and exact steps to reproduce the issue?

Marking as incomplete for now...

I have tested with 2.79b and cannot reproduce the bug either.

Ako Zoom (AkoZ) added a comment.EditedApr 13 2018, 12:41 PM

ok i 'll send 3files ..
for now ..measureit V 1.7.0
i'm on linux version xubuntu ...
.. on last file .. i've sent the modified file of measureit.main.py... where the bug is shown (about if .. )

    1. on one pict : mode local where NO measureit shown...:
    2. other pict: mode global: measureit OK:
  1. here a . blend file where the bug is .. (?) for me
Ako Zoom (AkoZ) added a comment.EditedApr 13 2018, 1:21 PM

OK .. i reproduce the Exact steps for others to reproduce the error
for the https://developer.blender.org/rBAdc6704ab42317256a0cad14728f275ee542f9904 BUG

MeasureIt Layer bug.blend522 KB

Turn on measurements with Toolshelf> Display tab> MeasureIt Tools panel> Show.
The measurement should currently be visible. Press '2' to switch to layer 2. The measurements disappear.

and it's OK .. measureit is right in local too!!: i mean : in this file tested for BUG i got NO bug !
layer 1 or 2 changes nothing, i can see measureit..,even in local mode


Also it seems it's my file .. something is corrupted there .. ;) !!
yep ! .. i also try with a new file: just a cube and all is ok
my file is a complete hard and old version pack from monthes .. till today, saved and saved.

Ako Zoom (AkoZ) closed this task as Resolved.EditedApr 13 2018, 1:36 PM
Ako Zoom (AkoZ) claimed this task.

As i see no bug with new file .. i go more in my own file:
also i found that with the layer management..
in local mode,
the layer of the object is OFF, even object is seen .. also .. measureit stays OFF as its layer !


BUT there is only 1 object ,and as i return bck to my entire file, there are more objects to be hidden.

may be said: when an object is in local MODE,
measureit must be in a same layers state as its measured object.
its layer may be forced turned ON and not OFF .. ;) ?

cheers to help ! thanK you all for the great work !!

Ako Zoom (AkoZ) reopened this task as Open.EditedApr 13 2018, 1:48 PM

BUT .. as i go back to the entire file ! .. i find that when i make my object layer to ON to see measureit...
THEN i got ALL the layer objects i've hidden... yep ok i got measureit but not in the "only" way which is to see measureit of the parts objects and not all...
Also it is till a bug for me ...
SO i go back with my corrected file (not added the new lines of V1.7.0)
and till there is no bug with the MeasureIt Layer bug.blend522 KB when i change layer 1 to 2 .. !!
may we find a solution .. it seems to be a layer management problem

Philipp Oeser (lichtwerk) raised the priority of this task from Needs Information from User to Confirmed, Medium.

actually this has to do with this fellow

If you use view local layers and additionally go to local view it fails with the newest version, will check in a bit...

nBurn (nBurn) added a comment.EditedApr 14 2018, 5:39 PM

@Philipp Oeser (lichtwerk), I checked and AkoZ was correct, it's a layer management problem. Part of the problem is Blender's weird "view-dependent layers" option. For some reason Blender sets any layers (in "context.space_data.layers") attached to the current view to "False" if you disable the "Scene Layer Lock" option and switch to Local View. That is what prevents any measurements from showing up. I don't think rolling back rBA8ca82b7d or adding a quick fix like:
"if True in bpy.context.space_data.layers do old_behaviour"
are good options as both of those brings back the view layer inconsistency bug which is (IMO) worse than this Global / Local issue.

I think I know how to fix this, but it might be a while before I can implement it as it could require a lot of changes to MeasureIt's visibility checks. MeasureIt's drawing code needs to be changed so it only displays measurements for active/selected mesh object(s) when in "local" view instead of using visibility layers. Using layers to determine what to draw when in local view can cause this to happen (I'm surprised no one reported this bug before):

Philipp Oeser (lichtwerk) lowered the priority of this task from Confirmed, Medium to Normal.Apr 14 2018, 6:23 PM

OK, thanx for checking back. Agree with your analysis (was just pointing out that this has nothing to do with rBAdc6704ab4 and reverting rBA8ca82b7d would actually fix this report -- but of course reintroduce other issues).
We'll just let this open then see how to fix both Global/Local AND view layers when time comes... OK?

In fact, i used the LOCAL way to get my cotation seen on 1 or 2 objects at once.
As those obects are on the same layer, the way you prescribe is to put the other objects on a stand-by layer
till i get the print of my object cotation then one by changing of layer for each object...
a bit longer workflow than not to see as old version ( and as i dont see any pb about layers for measureit except this one ;) )

Thank you guys for the search and code..
then i found an other bug about .. manipulator !! worse !

@Philipp Oeser (lichtwerk) I was not entirely sure if you were suggesting a rollback or not, but Ako was.

I am also not sure if we will need to leave this open long, I already have a fix working on my local repo (there was not nearly as much code needing to be changed as I first thought). I want to do some more tests, but if all goes well I will commit my fix.

Yeah !! all right ! HERE measureit_main.py the good file to replace for 2.79b (1.7.0-> 1.7.1 measureit version) tabbed and spaces (for clean python writing).
Thank you so much for the fast (easy? / competitive) resolution for local measureit viewing !

Ako Zoom (AkoZ) renamed this task from Measureit 2.79b not shown when in "/" mode (hide other unselected) to Measureit 2.79b not shown when in "/" (local) mode.
Ako Zoom (AkoZ) renamed this task from Measureit 2.79b not shown when in "/" (local) mode to Measureit 1.7.0 in Blender2.79b not shown when in "/" (local) mode.