Page MenuHome

Multi-Object Properties Editing
Closed, ResolvedPublic

Tokens
"Love" token, awarded by Arkhangels."Love" token, awarded by duarteframos."Love" token, awarded by lcs_cavalheiro."Love" token, awarded by SteffenD."Love" token, awarded by sebastianmroy.
Authored By

Description

In Blender 2.8, we want to make it easier to set values for multiple objects or bones at once. In version 2,79 you can do this, but you have to right-click on a value after you've changed it at pick Copy to Selected from the menu. This is both slow and unnecessary. You can also hold Alt to affect all selected items, but this is not discoverable, and clashes with the popular Emulate 3 Button Mouse option, which takes away the ability to use the Alt key here.

Instead we want to make it so you can simply type a value, hit return, and that value then automatically gets propagated to all the relevant objects or bones.

Note: For technical reasons, we cannot make this work for nodes, because it's not easy to figure out how to find the correct pair mapping. So we need a way for the user to know which items can work and which items cannot. We also cannot do real-time compares of 3000 selected objects to display special indicators if values are the same or they differ. So we have to work around these limitations.

This is how we think we can solve this:

If the user has more than one object or bone selected, and then goes to edit a value that is valid for multi-object editing, we display a 'selected' outline around the property, to indicate that this will affect all selected items. The user simply types a value and hints return.

Additionally, we want to make it easy to type in relative values too. We allow this by using =, so the user can type '= -3' to subtract 3 from the value on all selected objects or bones, like so:

To edit the value of only the active item, even if multiple ones are selected, we can invert the Alt-key behaviour, so holding Alt will only edit the value on the active item.

Details

Type
Design

Event Timeline

William Reynish (billreynish) triaged this task as Normal priority.
Dalai Felinto (dfelinto) closed this task as Resolved.Apr 30 2018, 10:08 AM

Hello. If I can make a suggestion... on top of the proposed ideas, which I think are great, would be to use the Alt+Edit current behavior, but inverted.
On 2.79, if you select multiple objects and press Alt before you change something (not everything is supported), this change propagates to everything selected.
Now, on the proposal of automatically changing everything and showing it through an outline/color is great, but it would also be handy to be able to to the opposite: without deselecting everything, changing only the last (current active) selection. And my proposal is to use the current Alt+click behavior. If the user simply hovers over a field or checkbox, it is outlined and everything selected can be changed. But if the user pressed Alt beforehand, the outline would disappear and then only the (current active) last selection is changed (without the need of deselecting everything).

@Evandro Costa (Arkhangels): Yes, in fact we already did discuss exactly that. Updated the description to reflect this.

This task is marked "Closed, Resolved" but the functionality is not yet inside 2.80. So is this still on the agenda?

Resolved here means the design is approved. There is a separate task about implementing this: T54987: Implement Multi-Object Properties Editing.

What about how object properties values are displaye·d?

I think if default behavior will be editing multiple values, so as displayed values should also be somewhat consistent with that. With "?"/"-" mark or averaged value.

Eg like that:

That is seemingly not possible technically. The issue is that then Blender has to compare many many values to determine if they are the same or not, which is actually a slow operation. The design described in the task gets around this limitation.