2.79 crashing after a few minutes, or when opening user preferences
Closed, ArchivedPublic

Description

System Information
Windows 10 64bit, gtx1060 6gb, 8gb ram, intel i7-7700
nvidia driver version 397.93

Blender Version
Broken: 2.79

Short description of error
Blender closes abruptly when opening the user preferences, or if I've been working for a few minutes, blender closes unexpectedly. I've tried updating my graphics drivers and reinstalling blender, but that doesn't seem to work. So far I haven't had issues like this with any other software.

Exact steps for others to reproduce the error
Based on a (as simple as possible) attached .blend file with minimum amount of steps

  1. open blender
  2. press ctrl,alt,u or choose "user preferences" from the drop down menu, or change an existing window to user preferences from the window tool bar.
  3. blender closes

alternately

  1. open blender
  2. wait or work for about 5-10 minutes
  3. blender closes

Details

Type
Bug
Philipp Oeser (lichtwerk) triaged this task as Incomplete priority.Jun 6 2018, 10:29 AM

reg. User Preferences: We have had quite a lot of reports about this, as far as we can tell this is a bug in some graphic card drivers relating to using the same OpenGL context for multiple windows (something which seems not to be well supported especially for low-end cards).

Just a shot in the dark:

  • does this happen with the zipped version of blender as well? https://www.blender.org/download/Blender2.79/blender-2.79b-windows64.zip/
  • Could you try this dll and copying it so its located in the same directory as 'blender.exe' and run Blender normally (to verify it is an OpenGL error)
  • you could also run blender from the commandline with the -d option and post the output here as a .txt file here [maybe there's a hint in there]

Marking as incomplete until we have this out of the way...

As per your suggestions, I tried with the zipped version of blender, and saw no changes. when running blender from the command line with -d, here were the results

C:\Users\linco\Desktop\Animation\blender-2.79b-windows64\blender-2.79b-windows64>blender.exe -d
Switching to fully guarded memory allocator.
Blender 2.79 (sub 0)
Build: Thu 03/22/2018 09:59 AM Windows
argv[0] = blender.exe
argv[1] = -d
read file C:\Users\linco\AppData\Roaming\Blender Foundation\Blender\2.79\config\userpref.blend
  Version 279 sub 0 date 2017-09-11 10:43 hash 5bd8ac9
Read prefs: C:\Users\linco\AppData\Roaming\Blender Foundation\Blender\2.79\config\userpref.blend
read file C:\Users\linco\AppData\Roaming\Blender Foundation\Blender\2.79\config\startup.blend
  Version 278 sub 0 date 2017-02-08 13:50 hash 3c04373

ordered
found bundled python: C:\Users\linco\Desktop\Animation\blender-2.79b-windows64\blender-2.79b-windows64\2.79\python
archipack: ready
archimesh: Imported multifiles
read file
  Version 262 sub 3 date unknown hash
read file
  Version 268 sub 5 date unknown hash

Finally, I moved the .dll file into the same directory as blender and noticed no change when attempting to open the user preferences, but I did notice a significant slow down of responsiveness with blender as a whole. I took the liberty of running blender like this from the command line with -d and noticed two new warnings, so here is the output from that.

C:\Users\linco\Desktop\Animation\blender-2.79b-windows64\blender-2.79b-windows64>blender.exe -d
Switching to fully guarded memory allocator.
Blender 2.79 (sub 0)
Build: Thu 03/22/2018 09:59 AM Windows
argv[0] = blender.exe
argv[1] = -d
read file C:\Users\linco\AppData\Roaming\Blender Foundation\Blender\2.79\config\userpref.blend
  Version 279 sub 0 date 2017-09-11 10:43 hash 5bd8ac9
Read prefs: C:\Users\linco\AppData\Roaming\Blender Foundation\Blender\2.79\config\userpref.blend
read file C:\Users\linco\AppData\Roaming\Blender Foundation\Blender\2.79\config\startup.blend
  Version 278 sub 0 date 2017-02-08 13:50 hash 3c04373

ordered
Warning! Legacy WGL is unable to select between OpenGL versions.found bundled python: C:\Users\linco\Desktop\Animation\blender-2.79b-windows64\blender-2.79b-windows64\2.79\python
archipack: ready
archimesh: Imported multifiles
read file
  Version 262 sub 3 date unknown hash
read file
  Version 268 sub 5 date unknown hash
Warning! Legacy WGL is unable to select between OpenGL versions.
C:\Users\linco\Desktop\Animation\blender-2.79b-windows64\blender-2.79b-windows64>

I hope this helps narrow down the issue

Thx, for checking (you can remove the dll again to regain normal performance)

What happens if you

  • Try to disable any running antivirus.
  • Ensure you have no python executable available in your %path% envvar.
  • Try to start Blender in factory settings (--factory-startup commandline option) (this will ensure whether this is a userpref or addon issue or not).
  • or rename C:\Users\linco\AppData\Roaming\Blender Foundation\Blender\2.79 temporarily to something like 2.79_bak

I have no running anti-virus in the first place, I made sure there was no python executable available in my %path% envvar, I tried to start blender in factory settings from the command line, but blender closed immediatly and only the following information was printed to the command line:

C:\Users\linco\Desktop\Animation\blender-2.79b-windows64\blender-2.79b-windows64>blender.exe --factory-startup -d
Switching to fully guarded memory allocator.
Blender 2.79 (sub 0)
Build: Thu 03/22/2018 09:59 AM Windows
argv[0] = blender.exe
argv[1] = --factory-startup
argv[2] = -d
read file
  Version 272 sub 2 date unknown hash unknown

ordered
 OBCube
 OBLamp
 OBCamera
AL lib: (EE) UpdateDeviceParams: Failed to set 44100hz, got 48000hz instead
found bundled python: C:\Users\linco\Desktop\Animation\blender-2.79b-windows64\blender-2.79b-windows64\2.79\python

C:\Users\linco\Desktop\Animation\blender-2.79b-windows64\blender-2.79b-windows64>

finally I renamed the 2.79 file to 2.79_bak, which stopped blender from opening at all and returned the exact same information the the command line as attempting to run in factory settings:

C:\Users\linco\Desktop\Animation\blender-2.79b-windows64\blender-2.79b-windows64>blender.exe -d
Switching to fully guarded memory allocator.
Blender 2.79 (sub 0)
Build: Thu 03/22/2018 09:59 AM Windows
argv[0] = blender.exe
argv[1] = -d
read file
  Version 272 sub 2 date unknown hash unknown

ordered
 OBCube
 OBLamp
 OBCamera
AL lib: (EE) UpdateDeviceParams: Failed to set 44100hz, got 48000hz instead
found bundled python: C:\Users\linco\Desktop\Animation\blender-2.79b-windows64\blender-2.79b-windows64\2.79\python

C:\Users\linco\Desktop\Animation\blender-2.79b-windows64\blender-2.79b-windows64>

After renaming the file to 2.79 and confirming I could still run blender and duplicate my issues, I went ahead and ran an experimental version of blender 2.8 (blender-2.80-2349b97-win64) and found that (despite other bugs and crashes expected with any experimental software) I could open the user preferences in blender 2.8, but not in 2.79. Perhaps this information might help you narrow down the problem, since it was evidently fixed between these two versions.

Bastien Montagne (mont29) closed this task as Archived.Jul 12 2018, 4:12 PM
Bastien Montagne (mont29) claimed this task.

Thanks for the report, but I’m archiving it, because this is a specific hardware/driver related issue, no point investigating that now that all workforce is focused on 2.8. :)