Mouse wheel on buttons region header causes the whole space to flicker
Closed, ResolvedPublic

Description

System Information

Linux 64 bit, NVidia GTX1080.

Blender Version

Blender 2.8, rB3df809958b7, rB6d152c59971 (the former one seems to be a culprit commit)

Short description of error

Hover buttons space header with a mouse, scroll the wheel.

Details

Type
Bug
Sergey Sharybin (sergey) triaged this task as Unbreak Now! priority.

Note that I cant redo this on my system with 6d152c599712bf4024b29f86a6050daba2919397

Campbell Barton (campbellbarton) closed this task as Resolved.EditedJun 20 2018, 3:52 PM

Managed to redo - was caused by scroll bar drawing, finding the active action zone was causing a redraw.

Split this into find / refresh versions of this function, fixed by rB372754c164793e8e1b0d8a7f1f0dbe9fd432fdf3 - now merged.