Page MenuHome

Eevee - Irradiance Volume does not render correctly in the viewport
Closed, InvalidPublic

Description

I'm noticing what appears to me as a bug with Irradiance Volume (Light Probes) in Eevee. When creating an Irradiance Volume object and setting the viewport display method to Rendered, the light coming from the emitter mesh does not appear around the mesh itself, but gets piled up in a corner of the probe.

I'm using Linux 64bit Blender 2.8 build (Jun 16 2018 01:16:47). My OS is openSUSE Tumbleweed x64. My video card is a Radeon R7 370 (GCN 1.0) amdgpu.

Details

Type
Bug

Event Timeline

Blend file I used to replicate the issue.

Screenshots showing the result I get in the viewport versus the rendered result.

Philipp Oeser (lichtwerk) closed this task as Invalid.
Philipp Oeser (lichtwerk) claimed this task.

Thanx for reporting -- it's still a little early though to accept bug reports for 2.8 due to following policy:

Thank you for the report.
Currently we are aware of many issues in 2.8 and actively working to fix them.
But since replying to reports takes time, we have decided to limit bug reports to module team members.

I think lightprobes are actually subject to ongoing change atm (temp-eeveelightcache branch), so letting @Clément Foucault (fclem) know, but closing anyways (see above policy)

This is likely just the irradiance grid not finished baking. Given the high resolution you set, it's going to take a while. There will be a progress bar for that in the future.

Sorry for not being aware of 2.8 reports being closed. I was going to report something else for this version, but now I know to wait until 2.8 reports are open.

Baking is probably the cause: The issue seems to slowly improve the longer you wait. It still looks like a bug as the light initially shows in a corner of the volume, oppositely to just the quality improving while positioning is always correct.

It is working as intended. It's computing lighting at a lower resolution and refining overtime to give you realtime feedback. It is not centered because of implementation limitation. Making it centered would make all shaders slower.