Blender crashes when i want to open attatched File
Closed, ResolvedPublic

Description

System Information
Windows 10

Blender Version
Broken: blender-2.80-1112f49-win64

Short description of error
Blender crashes when i want to open attatched File

Details

Type
Bug
Bastien Montagne (mont29) triaged this task as Incomplete priority.Jul 11 2018, 11:23 AM
Bastien Montagne (mont29) edited projects, added BF Blender: 2.8; removed BF Blender.

File opens fine here, bug may have been fixed yesterday, can you please check and report with next build from the buildbot?

I can confirm Blender crash opening this file on Windows with blender-2.80.0-git.17bc056-windows64 and blender-2.80.0-git.1112f49-windows64 :

F:\blender-2.80.0-git.17bc056-windows64>blender --debug --debug-memory --factory-startup
Switching to fully guarded memory allocator.
Blender 2.80 (sub 20)
Build: Wed 07/11/2018 07:13 AM Windows Release
argv[0] = blender
argv[1] = --debug
argv[2] = --debug-memory
argv[3] = --factory-startup
read file
  Version 272 sub 2 date unknown hash unknown
AL lib: (EE) ALCmmdevPlayback_open: Device init failed: 0x80070490
found bundled python: F:\blender-2.80.0-git.17bc056-windows64\2.80\python
Read blend: F:\Test\Schnecke - Copy.blend
read file F:\Test\Schnecke - Copy.blend
  Version 279 sub 0 date 2017-09-11 10:43 hash 5bd8ac9
Error   : EXCEPTION_ACCESS_VIOLATION
Address : 0x00007FF649357340
Module  : F:\blender-2.80.0-git.17bc056-windows64\blender.exe
Bastien Montagne (mont29) raised the priority of this task from Incomplete to Confirmed.Jul 11 2018, 2:48 PM

Thanks for checking, might be an issue specific to windows then…

Julien Soler (Ping) added a comment.EditedJul 11 2018, 8:33 PM

It also crash with blender-2.80.0-git.a6340a5-windows64. I don't know how to get more informations (logs) on windows but I'll be happy to help :)

race condition caused by rBd7aa51a50c65d06108a7979265226d1746d89da1 in drw_deferred_shader_add when there's already a job running there's this bit of code

if (old_comp) {
		BLI_spin_lock(&old_comp->list_lock);
		BLI_movelisttolist(&comp->queue, &old_comp->queue);
		BLI_spin_unlock(&old_comp->list_lock);
		/* Do not recreate context, just pass ownership. */
		comp->gl_context = old_comp->gl_context;
		old_comp->gl_context = NULL; <--------------------- UH OW!
	}

if this get executed before the previous job on another thread calls

	void *gl_context = comp->gl_context;

	WM_opengl_context_activate(gl_context);

you get a neat null deference when it tries to activate the context.

this one is for @Clément Foucault (fclem)

I fixed the race condition (rB6a05c14a8a24219e43ea82012762e63bd3b2a93f) but could not reliably test if this bug is gone.

Can someone test again please? @Julien Soler (Ping) @Timon (timonkrebs) @LazyDodo (LazyDodo)

tested a few times, seem all-right now

Clément Foucault (fclem) closed this task as Resolved.Jul 27 2018, 5:36 PM