Blender crash at startup
Closed, InvalidPublic

Description

System Information:
macOS High Sierra version 10.13.6
Gpu: NVIDIA GeForce GTX 1080 Ti 11263 MB

Blender Version:
Blender 2.79b

Short description of error:
Blender crash at startup

Latest and older versions of blender crash at startup. Blender 2.80 starts but is buggy in other ways...

Terminal output:
Segmentation fault: 11

blender.crash.txt:

Blender 2.79 (sub 0), Commit date: 2018-03-22 14:10, Hash f4dc9f9

backtrace

0 blender 0x0000000100c837ea BLI_system_backtrace + 58
1 blender 0x000000010013f6fa sig_handle_crash + 362
2 libsystem_platform.dylib 0x00007fff75ca0f5a _sigtramp + 26
3 ??? 0x000000000000ffff 0x0 + 65535
4 blender 0x00000001007de059 GPU_invalid_tex_init + 201
5 blender 0x00000001007d110d gpu_extensions_init + 509
6 blender 0x00000001007d263a GPU_init + 26
7 blender 0x0000000100165b61 wm_window_ghostwindows_ensure + 449
8 blender 0x000000010013ffd1 WM_check + 113
9 blender 0x000000010014d9ed wm_homefile_read + 1309
10 blender 0x0000000100152db5 WM_init + 261
11 blender 0x000000010013c5b8 main + 696
12 blender 0x000000010013c2ec start + 52

Details

Type
Bug
Bastien Montagne (mont29) triaged this task as Incomplete priority.Jul 11 2018, 11:11 AM

Please:

  • Ensure both your OS and drivers are fully up-to-date (and use official GPU drivers, not those provided by windows or tablet/laptop maker or open source ones in linux distributions).
  • Try to start Blender in factory settings (--factory-startup commandline option) (this will ensure whether this is a userpref or addon issue or not).
  • Try to tweak your GPU driver settings (e.g. try different values between 'performance' and 'quality' if you have such slider, etc.).
  • Try to start in software OpenGL mode (use the blender-softwaregl distributed with official blender, will be slow, but will show whether this is a driver issue or not).

Thank you. Did this and it still crashes. Don't know how to open in OpenGL mode. Can you describe how?

As said above, you should have a blender-softwaregl script next to blender executable, that will launch it with software OGL rendering.

Also, please try to run Blender from the command line with --debug-gpu option and attach as text file here any error printed out in the console (do not paste it directly in comment).

Can't find any OpenGl script inside blender app. Nor do I find any information on how to on Google. Here is the text file output after --debug-gpu command.

Bastien Montagne (mont29) raised the priority of this task from Incomplete to Normal.

@Arto Kitula (akitula) don’t we have a software-gl script in OSX builds, like we do for linux ones? Anyway, from the log it does looks like a GPU/driver issue, guess you are the best guy to handle that report…

Arto Kitula (akitula) lowered the priority of this task from Normal to Incomplete.Aug 5 2018, 8:57 PM

@Omid (Khanman) Could you give your system info also. (which mac do you have?)

More than a week without reply or activity. Due to the policy of the tracker archiving for until required info/data are provided.