Page MenuHome

Auto-keying is broken (needs a refresh)
Closed, ArchivedPublic

Description

System Information
Xbuntu / AMD

Blender Version
ccc9f47

Short description of error
If you have auto-keying turned on, move an object to create a new key and then move that key in the dopesheet then it will not refresh the animation, by for example selecting all the keys and moving them back and forth.

Exact steps for others to reproduce the error
New file
Delete everything in the scene
Split the Timeline so you also have also the Dopesheet
Toggle on the auto-key (in the Timeline)
Create an armature
Go to pose mode
On frame 10, insert a key (LocRotScale) for the bone in the default position
On frame 30, move the bone to the far right of the screen
On frame 20, rotate the bone upside down
In the Dopesheet, right-click select the key on frame 20 and move it to frame 0
Now scrub the Dopesheet
...the poses are all wrong...
Now select all the keys in the Dopesheet and move them but right-click to undo (this refreshes them)
Now scrub the Dopesheet
...now the poses are all right...

Details

Type
Bug

Event Timeline

Bastien Montagne (mont29) triaged this task as Incomplete priority.Jul 25 2018, 3:07 PM

Looks like this has already been fixed? At least, cannot reproduce with latest 2.8branch…

Bastien Montagne (mont29) closed this task as Archived.Aug 4 2018, 2:58 PM

More than a week without reply or activity. Due to the policy of the tracker archiving for until required info/data are provided.