Crashes in a certain sequence of events
Closed, ResolvedPublic

Description

Blender Version
Broken: blender-2 80-d28d202-win64-vc14
Worked: (optional)

Short description of error
While clicking on either the LookDev or Render icon Blender crashes. Only if certain criteria have been implemented.

Exact steps for others to reproduce the error

  1. Create a sphere
  2. Add Subsur Modifier
  3. Create 3 Materials
  4. Go back to Subsur Modifier panel (this is the important part)
  5. Save and Exit Blender
  6. Open the file (Subsur panel will be there) click on either the LookDev or Render icon in top right corner of viewport and it will crash.
  7. If you open the file again and go immediately to the Material panel... then click on either the LookDev or Render icon it doesn't crash. If you go back to the Modifier panel and do the same it doesn't crash
  8. It only crashes if you save it while the Modifier panel is open (with 3 or more materials), Exit Blender and open the file again and click on the LookDev or Render icon while the Modifier panel is open before you go to any other properties panel.

Based on a (as simple as possible) attached .blend file with minimum amount of steps

Details

Type
Bug

Please for the future reference, attach the system-info.txt by dragging and dropping the file into the comment field or using the Upload File button (the second on the right). Pasting it directly makes the report difficult to read and breaks up the formatting.

Sorry, first time I've ever done this. I've fixed the formatting.

Bastien Montagne (mont29) triaged this task as Incomplete priority.Jul 25 2018, 3:27 PM

Cannot reproduce the issue here with current 2.8. @Peter Vojzola (PuckerFactor) mind checking again with latest build? Thanks.

I still had the same problem up until Hash=48759580839 . This latest version released on 28th July no longer causes the crash.

Bastien Montagne (mont29) closed this task as Resolved.Aug 5 2018, 9:36 AM
Bastien Montagne (mont29) claimed this task.

Cool, then we can consider it as solved, thanks. :)