Page MenuHome

Blender 2.79, latest build - undo doesn't work in certain cases
Closed, ArchivedPublic

Description

System Information
Windows
GeForce GTX 950/PCIe/SSE2

Blender Version
Broken: (2.79 (sub 6), branch: blender2.8, commit date: 2018-08-01 17:44, hash: e50a3dd4c4e, type: Release build date: 01/08/2018, 19:44)
Worked: (2.79b , hash: f4dc9f9d68b, Date: 2018-03-22 )

Short description of error
Undo doesn't work . In certain cases .

Exact steps for others to reproduce the error

  1. Open the blend file.
  2. Apply a boolean modifier on the big object
  3. Set it to difference
  4. Set the small rectangle to be the cutter
  5. Deselect All
  6. Press CTRL+Z ( it doesn't work the boolean it's not removed )

Details

Type
Bug

Event Timeline

Catalin (giakaama) renamed this task from Blender 2.79 LATEST to Blender 2.79, latest build - undo doesn't work in certain cases.
Bastien Montagne (mont29) triaged this task as Needs Information from User priority.

Not sure what you mean exactly, what do you get as result and what do you expect?

Please follow our submission template and guidelines, also read these tips about bug reports, and make a complete, valid bug report, with required info, precise description of the issue (only ONE issue per report!), precise steps to reproduce it, small and simple .blend and/or other files to do so if needed, etc.

Not sure what you mean exactly, what do you get as result and what do you expect?
Please follow our submission template and guidelines, also read these tips about bug reports, and make a complete, valid bug report, with required info, precise description of the issue (only ONE issue per report!), precise steps to reproduce it, small and simple .blend and/or other files to do so if needed, etc.

The result I get is that the boolean doesn't get's removed by Ctrl+Z, the undo doesn't undo the opperation, it does nothing . I want the same result I get with 2.79b , hash: f4dc9f9d68b from Steam .
I've completed every step you have in submission template ... I don't know how many more info to give ...

Catalin (giakaama) raised the priority of this task from Needs Information from User to Needs Triage by Developer.Aug 2 2018, 10:21 PM

Cant redo this.

The de-select action is skipped. but the boolean is undone as expected.

From what I can tell the only bug is that changing the boolean target object is not causing an undo step.

Cant redo this.
The de-select action is skipped. but the boolean is undone as expected.
From what I can tell the only bug is that changing the boolean target object is not causing an undo step.

Agreed, just found out that I get this behavior because I sync Blender over Dropbox . When do those steps localy they work . So this task should be closed .

Catalin (giakaama) closed this task as Archived.Aug 3 2018, 8:49 AM