Page MenuHome

Using Strip Modifier on Scene Strip with Alpha Over Affects the Alpha Area
Closed, ResolvedPublic

Description

System Information
Operating system: Arch Linux
Graphics card: GTX 1060

Blender Version
2.79b

Short description of error
If I import a scene with a transparent background into the VSE as a scene strip and set the blend type to "Alpha Over," any curve modifier will affect the alpha-ed area too, flooding the area the strip covers with the adjusted color. It appears this only occurs with scene strips. Image and video strips with an alpha background appear to behave as expected.

Exact steps for others to reproduce the error

  1. Create a new scene with an alpha background.
    • Add some meshes, lighting, etc to that scene
    • Add a camera to that scene pointed at the stuff you added
    • Set the scene's shading to transparent
  1. Add the scene from step 1 to the VSE
    • Switch to video editing mode
    • Change the scene back to the original Scene instead of the one created in step 1
    • Add the scene from step 1 into the sequencer
    • Change the scene strip's "Blend Type" to "Alpha Over"
    • In a channel below, add an image strip or a movie, or even another scene strip
  1. Adjust the color of the scene strip using a curve modifier
  2. Render out the image and notice that the curve modifier is affecting the area that should be alpha.

Details

Type
Bug

Event Timeline

Looks like there's a problem with the 32-bit float image.

It works correctly with 8-bit PNG images,
does not work if you activate the "Convert to Float" option,
and does not work with a 32-bit EXR file.

Bastien Montagne (mont29) triaged this task as Confirmed, Medium priority.

Looks like a mismatch between premultiplied and straight alpha… bytes are always straight iirc, while float are usually premultiplied in sequencer…

Daniel Oakey (doakey3) closed this task as Resolved.Jan 2 2019, 9:33 PM