Page MenuHome

Roughness (at least for glossy shader node) is broken if you link in files saved in older blender versions
Closed, DuplicatePublic

Description

System Information
All Systems

Blender Version
Broken: 2.74.4 and later builds

Worked: 2.72.2

If I link in a library with glossy shader nodes saved with older blender versions (< 2.79.4) new blender does not convert the roughness value properly. Instead blender uses the roughness without conversion. For instance 0.05 should be square rooted to 0.224 but stays at 0.05 so the material is too glossy now.

Details

Type
Bug

Event Timeline

Bastien Montagne (mont29) triaged this task as Needs Information from User priority.

Please follow our submission template and guidelines, also read these tips about bug reports, and make a complete, valid bug report, with required info, precise description of the issue (only ONE issue per report!), precise steps to reproduce it, small and simple .blend and/or other files to do so if needed, etc.

ronald engel (ronald8e) closed this task as Invalid.EditedAug 9 2018, 11:35 AM
ronald engel (ronald8e) claimed this task.

I'm not sure what you mean with incomplete.

If I render 2.79.2 files with linked libraries in blender 2.79.6 the roughness in the linked objects is wrong. It seems it is/was a problem with 2.79.2 and 2.79.3 builds since it worked with files saved with official 2.79 build.
So I guess we just re-save all files with 2.79.6 and all should work again.

Yevgeny Makarov (jenkm) reopened this task as Open.

When you open a 2.79b file in 2.79.6, the Roughness value is converted. rB7613ffc944eb
When you link a 2.79b file, the Roughness value remains unchanged.

Brecht Van Lommel (brecht) raised the priority of this task from Needs Information from User to Confirmed, Medium.