Page MenuHome

Clamping Direct/Indirect Should be Renderlayer Specific Instead of General Render Setting
Closed, ArchivedPublic

Description

Windows 10 GTX 1060
Blender 2.79b

Hi,

During production we noticed that the clamping value was applied to all render passes when rendering with Cycles. When working with technical passes, Zdepth, Normal, WorldPosition passes it is undesirable to apply clamping, especially when working with compositing software like Nuke.

That is why the user should be able to exclude clamping to certain render layers or move the clamping parameters to the renderlayers.

Thanks.

Greetings,
Beau

P.S. it's hard to see the issue in the .blend file but it creates distorted coordinates in Nuke and possibly in Blender compositing

Details

Type
Bug

Event Timeline

Bastien Montagne (mont29) triaged this task as Low priority.

@Brecht Van Lommel (brecht) @Sergey Sharybin (sergey) while much more like a feature request than a bug, think that totally make sense… Maybe change the task to TODO type?

Well, this is like trying to simulate data pass with a light setup, which is already kind of weird. So probably this is something to look at as well.

But them, being able to do such an "overrides" is really what sounds belongs to, well, override system :) Think pushing overrides forward is the way to go. If such a feature is added now as a less generic option, that'd give some pain when we'll have to keep compatibility once proper overrides are done.

Brecht Van Lommel (brecht) closed this task as Archived.Sep 3 2018, 4:37 PM

This is indeed a feature request, that is planned to be solved in the future with overrides in 2.8. The other thing is that we should add support for a world position pass at some point.

Either way, not a bug to be handled in the tracker.