Page MenuHome

OSX Mojave wrong interface scaling
Closed, ResolvedPublic

Description

System Information
OSX Mojave

Blender Version
Broken: 2.79 and 2.80 dailies (guess the official builds as well)
Worked: Previous OS's

Short description of error
On OSX Mojave and HiDPI screen (iMac 2015 5k) interface is scaled wrong (way too large)

Exact steps for others to reproduce the error
Installed OSX Mojave.
Compiled blender (2.79 and 2.80)
Opening Blender shows an unreadable interface. You can barely see some buttons (all very large)
It's not corrupted.. just extremely large.
Pressing OSX "Full Screen" button or starting in OSX "Low Resolution Mode" fixes it temporarily.. but saving settings not.

I think the doubling of the interface on HiDPI now has to be scaled 50% or something.. My guess is that everything is 4x too large

Thanks for looking into it..
I'm back on Sierra.. btw ;-)

Event Timeline

Roel Koster (kostex) added a comment.EditedSep 25 2018, 1:41 AM

On request some screenshots..


remark:
The last screenshot is a maximized main screen and then opened preferences window
As soon as I resize that window it refreshes with the correct scaling

Brecht Van Lommel (brecht) triaged this task as Needs Information from User priority.

I couldn't reproduce the error on macOS 10.14 with MacBook Pro, Retina 15-inch Early 2015. The UI appears to be scaled correctly in both 2.79 and 2.80.

Does the same issue happen with factory settings? By running Blender from the terminal like this:

./blender.app/Contents/MacOS/blender --factory-startup

Is there anything non-standard about your macOS system settings? Does changing any of the Display settings avoid the issue? Do you have any external displays connected?

I couldn't reproduce the error on macOS 10.14 with MacBook Pro, Retina 15-inch Early 2015. The UI appears to be scaled correctly in both 2.79 and 2.80.
Does the same issue happen with factory settings? By running Blender from the terminal like this:

./blender.app/Contents/MacOS/blender --factory-startup

I got this same startup screen as on screen erlier. And i can tell the same as @Roel Koster (kostex), when i resize window it start works perfectly.
Start of Blender 2.8 on Mojave - Movie

Is there anything non-standard about your macOS system settings? Does changing any of the Display settings avoid the issue? Do you have any external displays connected?

I installed if yesterday and the only changes from pure macOS will be :

  1. defaults write com.apple.dock autohide-delay -float 0; killall Dock
  2. defaults write com.apple.dock autohide-time-modifier -float 0; killall Dock

But when i go back to default state nothing change with blender on start.

Hi, For info...

I think I got it to work...
It seems related to the dark mode.

I was struggling also with the way thing are shown in the dark mode, so I went back to the light mode, but didn't like the aspect. I found this link http://mds.is/using-mojave-dark-mode-on-only-the-menu-bar-and-dock/ that explains how to get back to the dark only menu bar and dock (same as High Sierra).

Now when I launch Blender, zoom is OK. Full screen mode still causes some issues with display of menu content...

From what I'm guessing, the issue happens specifically when building with the macOS 10.14 SDK, which the daily builds use now.

That would mean 2.79b is unaffected, which seems to be confirmed by the reports. Except for T56972, but I'm guessing that is a mistake?

Hi,

I might have missed something, I'm using 2.79b. Dark mode seems to have cause issues. I also tested 2.80 beta, with dark mode I had the scaling problem...

For me the official 2.79b release worked fine, while the daily builds had the problem.

Regardless, we can't fix it retroactively. Try today's build, it should solve the issue.
https://builder.blender.org/download

Am I right to assume that only the blender 2.8 branch got your (perfectly working ;-) patch?
I've incorporated your patch in the master branch myself (personal use) but shouldn't it be in there officially? Still use the 2.79 daily a lot of course.

Thanks

We do not call builds from builder.blender.org 2.79b, that naming is for the official releases from blender.org.

The master branch and 2.79 build from builder.blender.org now includes the fix as well.

For info
I downloaded from "builder.blender.org" and tested them in the configuration that works for me with the 2.79b version (dark mode modified as described here http://mds.is/using-mojave-dark-mode-on-only-the-menu-bar-and-dock/ )

blender-2.79.0-git20181001.786870e26f8-x86_64 => Crash (attached crash report)

blender-2.80.0-git20181001.3cd98d9ef7e-x86_64 => no crash

Roland Terver (Warun) reopened this task as Open.Oct 1 2018, 9:27 PM

For me on today's compilation, everything is fine in both version 2.79 and 2.8.

Brecht Van Lommel (brecht) closed this task as Resolved.Oct 4 2018, 5:54 PM
Brecht Van Lommel (brecht) claimed this task.

@Roland Terver (Warun), that crash looks like a different bug, please open a new report for that.

This seems to be a crash in the translation system, so mention if you had that enabled.

Hi,
I don't know how you can say that the bug is resolved... with 2.79b that's what I get{F4937104}

Now I might issue another bug because with the version 2.79 I have a crash...

Tell me if I missed something ...

If the official 2.79b release has the bug, we can't retroactively fix that, it will only be fixed in newer versions.

My understanding is the 2.80 daily build works ok for you, and that the 2.79 daily build crashes so we don't know if that one still has the problem?

Ok, the only thing that I did check until now was that for "pure" dark mode 2.80 was working. That's where the misunderstanding was...
2.80 works... in all modes...
I'll open another bug

Hi all and of course @Brecht Van Lommel (brecht) :) , Ok, so this issue is closed but, wanted to add my comments since as of the 27th of November I still have an issue with screen scaling. On macOS Mojave (see

for details of my system/setup and blender version) 2.80.34 is broken. The screenshot shows what is happening. The UI doesn't fill the application window and the mouse pointer is offset, the visual location of the pointer is not the same as where blender thinks it is, its offset by a similar amount to how the ui has been sort of shrunk from the size of the window its rendered in.

It makes blender totally unusable at the moment since its very hard to click on menus, I have to sort of guess where Blender 'thinks' the mouse pointer is and hope that the ui buttons 'light up' when they have focus so I know I can click on the button I want to activate.

Soooo, is this the same issue as above, or a new bug? If its a new one ( and I am guessing that it is since the above has been closed but my system still exhibits this issue) then I think a new issue needs to be opened, otherwise re-open this one. Also this behaviour doesn't happen for me in 2.79b official on the same system. 2.79b renders the UI correctly scaled to fit within the window and the mouse pointer has no offset from the visible pointer on the screen.