Page MenuHome

Cant select vertices and edges properly in mesh with armature modifier
Closed, ResolvedPublic

Description

System Information

Windows 10
i7 4790K
16 gb RAM
GTX 970

Blender Version
Broken: 2.8 Aplha 2 2018-09-24 20-26
Worked: (optional)

Short description of error

I can't select a mesh's vertices and edges properly when there is armature modifier activated in pose mode.

Exact steps for others to reproduce the error

  1. Open a rigged character
  2. Enable "display modifier in edit mode" in armature modifier
  3. move any of characters bones
  4. The mesh afected by this moved bone will get "hard" to select vertices. (It works fine in default position, rest mode or with "display modifier in edit mode" disabled)
  5. Edge selection does not work well as well. Only face selection works fine under these circumstances.

Details

Type
Bug

Event Timeline

Thanks for the report.
Please include a small .blend file that we can use to reproduce the bug. This would save us some time. Thank you.


Here's a file

Thank you. It looks like the vertex/edge selection still works on the undeformed mesh.
Can confirm that it does not work for vertices and edges, but does work for faces.

happened on my iMac (Retina 5K, 27-inch, 2017) on Version 2.80 (2.80 2018-11-30, Blender Foundation) too. Once deformed by an armature you need to click at the location where the vertices are supposed to be when undeformed to select them. So it's a guess game.

Also, once selected, they move in a funny way when you use G.

The bug seems to be fixed in the latest build! Must have been modified elsewhere. Thanks.

Brecht Van Lommel (brecht) claimed this task.