Page MenuHome

Lagging when rotating the view
Closed, DuplicatePublic

Description

System Information
iMac 4k 2017
Mac OS Mojave
Radeon Pro 560

Blender Version
Broken: 2.8 daily build
Worked: 2.79 and in render view (cycles) in 2.8 daily build

When you rotate the view with the middle mouse button, the view in the blender is slightly jammed. The problem does not occur on daily build 2.79 and when in 2.8 we enable the render view (ctrl + z) but only in cycles.

Event Timeline

Philipp Oeser (lichtwerk) triaged this task as Needs Information from User priority.

Hi there!

Could you be more specific in regards to "slightly jammed"? (maybe a screenshot or some further explanation would help...)
I can only imagine you are talking about overlays (wireframes, outlines etc) drawing very fast, whereas pixels rendered in cycles come in with some sort or delay? This would be expected behaviour I guess [and can only be improved upon if you lower Start Pixels under Properties Editor > Render > Performance > Viewport]

Marking as incomplete until we know a bit better what is meant here...

Hi! Thank you for your answer. It's about something else. Watch the video that I attached and tell if you know what's going on right now. Rotating the view with the mouse in blender 2.79 runs smoothly, and in 2.8 no.

OK, needs further investigation then...

Could you run blender with the --debug-gpu option and upload the output as .txt file here?

This comment was removed by Paweł (Wiggle).

There was only so much information when the terminal switched on:

iMac-Pawel:MacOS pawelbzyl$ ./blender --debug-gpu
Read prefs: /Users/pawelbzyl/Library/Application Support/Blender/2.80/config/userpref.blend
OpenGL debug callback is not available on Apple.
found bundled python: /Users/pawelbzyl/downloads/blender/blender.app/Contents/Resources/2.80/python
Saved session recovery to '/tmp/quit.blend'

Blender quit

Philipp Oeser (lichtwerk) raised the priority of this task from Needs Information from User to Needs Triage by Developer.Oct 6 2018, 3:50 PM

Hm, my bad (forgot debug is not available on Apple).
Out of ideas for the time being... back to "Needs Triage"

This has not been corrected yet. Will anyone fix it?

This report is a bit vague.
@Paweł (Wiggle) Can you enable the profiling option (F3 > Search "Debug Menu" > set to 23) and rotate the view until the numbers are more or less stable. Then take a screenshot and upload it here.

It should look like this :

Okay, I did what you told me. You have the results in the attachment. But I noticed one thing. The moment I turn on the debug mode at 23, the problem is solved and when I rotate the view with the mouse, everything runs smoothly. After the restart blender, the problem returns.

Does anyone already know what is the reason for this problem?

I have further conclusions about why this is happening. If I open the application not just on the whole screen, I will only scale it, everything works smoothly. The problem only occurs if the blender is displayed on the full screen.

In the monitor settings, if I set the resolution to the default for the monitor, it also works fine. I have the resolution set to scale: "more space". As I wrote earlier in 2.79, everything is fine. I can test this on previous versions 2.8 and check where it was good.

I hope someone will fix this problem because i can't work on it.

Does anyone work on this problem? It is very disruptive, and it seems to me that it is not difficult to repair. @Brecht Van Lommel (brecht)

We need to optimize drawing on macOS more still. It's unfortunately not simple to fix things like this, someone will likely need to spend a few weeks investigating macOS performance issues before the final 2.80 release.

@Brecht Van Lommel (brecht) Thank you for your response. It seems to me that the problem is not difficult to solve. I wrote above that after switching to the debuge mode set to 23, the problem disappears.

I have the same problem on a MacBook Pro 2016 i5 and Intel Iris Graphics 540 1536 MB. Latest macOS and latest blender 2.8 (Both on latest beta and latest git update (4ee29d3fdff) that I've built). I can confirm that enabling the debug menu to 23 does smooth the fps and running a more complex scene doesn't seems to slow down more the viewport. I'm available for further debugging.

Because of the screen recording it's much worse that it is normally but you get the idea

In today's compilation, it's better, but still in the debug mode set to 23, the blender is smoother.

Pawel on my end it's doesn't make any difference but you have faster and different hardware. I recorded a small video of the demonstration with and without the debug menu, it's difficult to see with the lag that it create but even without the record I don't see any difference.

@Hugo Lamarche (antares) I understand. I thought that in this build from December 3 this is not yet corrected, but it probably is. I also checked the imac 27 inch 2015 and MacBook Pro 2017 and there the problem also occurs. Can I check it on your build?

@Paweł (Wiggle) I'm not sure to understand but what I can tell you for sure is that the fix is in the latest macOS build : 63ac7c799c8
I only have the MacBook Pro 2016 to test it on, I will try it with latest build version on the website tonight, the one I try so far was the one I built with the fix.

Paweł (Wiggle) reopened this task as Open.Dec 3 2018, 3:38 PM

@Hugo Lamarche (antares) I checked on this build. So the problem, however, not solved: /

@Paweł (Wiggle) Alright, will check that later I don't have my Macbook with me. Either the problem is still here in some case or the build doesn't really contain the fix for some reason...

@Paweł (Wiggle) So I check and it work properly on my mac in build 63ac7c799c8. If you want to help track that bug I think you should go to blendercoders and setup a dev environnement to be able to test it with the blender coders (What I did) they don't have the proper hardware.

@Hugo Lamarche (antares) Okay, I can help. How can you configure this environment?

@Paweł (Wiggle) Honnestly if you follow this page it should go quite fast, the longest is to install xcode https://wiki.blender.org/wiki/Building_Blender/Mac. Keep in mind that you don't need cuda and also that for the make command to work you need to put cmake in your PATH (export PATH=$PATH:/path/to/cmake/bin/in/his/content/folder) If you need futher assistance go to blendercoders on freenode I'm sure they will be people to help you and I might be here as well as Abrases

hi,

Same issue with the latest build as of today :

2.80 Beta macOS 64 bit
December 20, 17:13:49 - 9ebd309e2b96

On a macbook Pro Retina 15' late 2013 running Mojave

One quick tip to make blender run fast on retina displays: open Blender's info.plist file and disable:
High Resolution Capable and Supports Automatic Graphics Switching.
This is the main setting change for opengl apps on my mac.
Right click on the Blender app and click show package contents.

For me after the introduction of these exchanges is all right.

I've the same issue ! I tried the debug thing and it works smoothly with (with 23)
Don't understand what I should change in the info.plist file. Should I delete the line of code or change the "true" to something else ?

@Camille (Ekiwnox) Should you change "true" to "false" in these two lines

Still an issue with the 2.80 Beta macOS 64 bit, 2826c2be545e.
It works on two of my Apple device on macOS Mojave smoothly.
I only have the problem with my Macbook retina on macOS Mojave with Intel HD Graphics 4000 1536 MB.

For me it doesn't change anything with the changes on the info.plist file !
Hope to have a solution soon for this issue !

I might have some insight that may help debug the problem. I am using macOS 10.14.2 on a MacBook Pro late 2013 (model 11,2), with Intel Iris Pro 1536 MB and Blender 2.80 2019-01-22. It seems as though the problem is related to displaying (or rather not displaying) certain Overlays. Steps to reproduce:

  1. Open a new scene with the Sculpting template. By default most overlays are toggled off. The 3D view lags when rotating with either the trackpad or Alt and mouse rotation (have three button mouse emulation enabled).
  2. Toggle on the Grid and X and Y axes Overlays (these seem to have the largest effect in my testing). Now rotation with both trackpad and Alt plus mouse are much smoother.

I have attached a screen recording showing the bug (did a quick sculpt to better illustrate but this is not necessary. Screen recording also reduces performance, without it rotation with said overlays toggled is smooth) :

Alright, not really sure if this will help with MAC, but I had similar problem on my laptop on Windows. I have 4k screen, so I thought that might affect it. After changing my screen resolution in the Intel settings to 1920x1080 blender started running smoothly, just like the 2.79.

Yes, in mac when changing the resolution also helps. Are the creators going to do something about it?