Page MenuHome

Toggling Between Shading modes causes a crash with heavy scenes
Closed, ArchivedPublic

Description

System Information

Windows 10, Intel(R) Core(TM) i5-6200U CPU and NVIDIA GeForce 940MX

Blender Version
Broken: e1293da0140
Worked: Yes

Short description of error
Open blender, hold Z key to switch over to render shading when in render mode the scene should behave rather sluggish in navigation, hold z key again to switch over to wireframe or x-ray, after doing this a couple of times it should produce a consistent crash. Please reference the file I sent you to further inspect the issue.

Exact steps for others to reproduce the error
switch from solid mode to rendered , then switch to wireframe, it should crash immediately.

Details

Type
Bug

Event Timeline

Philipp Oeser (lichtwerk) lowered the priority of this task from Needs Triage by Developer to Confirmed, Medium.

Cant get it to crash immediately, but after a lot of back and forth (sometimes also involving toggeling Single Color Shading which the file from this report is also using) I also get the crash.

backtrace etc. is the same as T57094 (and T56998). No expert here, so I will not merge these reports (even though very similar).

Hm, @Clément Foucault (fclem): mind having a look?

i have a version which is not crashing ,
here is its hash : b6c14437427

Is this still happening? I remember @pratik solanki (dragoneex) saying on IRC it was solved.

Brecht Van Lommel (brecht) closed this task as Archived.Mar 1 2019, 5:36 AM

Following bug tracker policy, closing report after 7 days due to insufficient information to investigate further. We can reopen the report if more information is provided.