Page MenuHome

2.8 Crash entering edit mode
Closed, ResolvedPublic

Description

System Information
platform: Linux
renderer: 'GeForce GTX 780/PCIe/SSE2'

Blender Version
version: 2.80 (sub 26), branch: blender2.8, commit date: 2018-10-13 21:55, hash: 55e3c17ccc1, type: Release

Short description of error
Blender crash when entering in edit mode when using instances of mesh (alt-d)
I've tried to recreate the setup, but it seems to work when I start from scratch.

Exact steps for others to reproduce the error
Open the attached .blend and enter edit mode with the selected object, that should make blender crash
If you delete the other one (named copy) , the crash shouldn't append anymore.

This is an even more narrowed down file, where I deleted all modifiers :

Details

Type
Bug

Event Timeline

happens with mac too

intel core i5 2.7 Ghz
8gb ram
NVIDIA GeForce GT 640 M 512 mb

Philipp Oeser (lichtwerk) triaged this task as Needs Information from User priority.Oct 16 2018, 11:11 AM

Hm, I cannot reproduce the crash (linux).
What I can reproduce is the behaviour of T57125 (element selection drawing not in sync between instances) -- but not the crash...

Could you attach the crash log?

It still append with today build , here is the crash log, tested on bug_02.blend

Is this still happening in the latest build?

Hey, I've just tested the buggy files and they work fine with the buid from October 31 !
Thanks !

Philipp Oeser (lichtwerk) closed this task as Resolved.Nov 5 2018, 6:40 AM
Philipp Oeser (lichtwerk) claimed this task.

thx for getting back, closing then