Page MenuHome

Blender crash during the sculpting (multires & smooth)
Closed, ArchivedPublic

Description

System Information
Windows 10, nVidia GTX 960,
Windows 10, nVidia GTX 950

Blender Version
blender-2.80.0-git.55e3c17ccc1-windows64

Short description of error
After some time of sculpting, Blender simple crush without any error

Exact steps for others to reproduce the error

  • Open New Sculpt project
  • Go to Multiresolution modifier,
  • Subdivide two time
  • Use random sculpt brushes on basic sfere.

After some time, Blender will simple crush.

In console I have following:

Read prefs: C:\Users\Boki\AppData\Roaming\Blender Foundation\Blender\2.80\config\userpref.blend
found bundled python: C:\Program Files\blender-2.80\blender-2.80.0-git.55e3c17ccc1-windows64\2.80\python
Traceback (most recent call last):
  File "C:\Program Files\blender-2.80\blender-2.80.0-git.55e3c17ccc1-windows64\2.80\scripts\modules\addon_utils.py", line 377, in enable
    raise Exception(f"Add-on '{module_name:s}' has not been upgraded to 2.8, ignoring")
Exception: Add-on 'io_scene_open_street_map' has not been upgraded to 2.8, ignoring
Traceback (most recent call last):
  File "C:\Program Files\blender-2.80\blender-2.80.0-git.55e3c17ccc1-windows64\2.80\scripts\modules\addon_utils.py", line 377, in enable
    raise Exception(f"Add-on '{module_name:s}' has not been upgraded to 2.8, ignoring")
Exception: Add-on 'io_scene_open_street_map' has not been upgraded to 2.8, ignoring
Error   : EXCEPTION_ACCESS_VIOLATION
Address : 0x00007FF7A1E50D15
Module  : C:\Program Files\blender-2.80\blender-2.80.0-git.55e3c17ccc1-windows64\blender.exe

Event Timeline

Philipp Oeser (lichtwerk) triaged this task as Confirmed, Medium priority.Oct 16 2018, 2:15 PM

Can confirm whenever multires is used and smooth() is involved (Smooth Brush, Mask Smooth) -- cannot reproduce using anything else...

backtrace (SculptSession->mpoly is NULL):

1   poly_get_adj_loops_from_vert    mesh.c            1252 0x28e9be1 
2   neighbor_average                sculpt.c          1515 0x2029d4d 
3   do_smooth_brush_mesh_task_cb_ex sculpt.c          1693 0x202c347 
4   palallel_range_single_thread    task.c            1050 0x2d01640 
5   BLI_task_parallel_range         task.c            1092 0x2d0181b 
6   smooth                          sculpt.c          1964 0x202e23b 
7   do_smooth_brush                 sculpt.c          1987 0x202e2e8 
8   do_brush_action                 sculpt.c          3620 0x203a2b4 
9   do_tiled                        sculpt.c          3981 0x203bfc0 
10  do_symmetrical_brush_actions    sculpt.c          4055 0x203c3ea 
11  sculpt_stroke_update_step       sculpt.c          4984 0x203ecd0 
12  paint_brush_stroke_add_step     paint_stroke.c    555  0x200b4be 
13  paint_stroke_modal              paint_stroke.c    1302 0x200d638

Will do some investigations [rB9a1ed2836507, rB3e86bb2d0bf1 or rB8e8952b7e363 might be involved?]

Philipp Oeser (lichtwerk) renamed this task from Blender crash during the sculpting to Blender crash during the sculpting (multires & smooth).Oct 16 2018, 2:16 PM

can confirm it happens on mac too
also if you use Cmd-Z (undo) it crashes straight away for me

Philipp Oeser (lichtwerk) closed this task as Archived.Oct 17 2018, 1:50 PM
Philipp Oeser (lichtwerk) claimed this task.

quoting @Brecht Van Lommel (brecht) from D3807:

Sergey is working on this, once the new subsurf/multires code is enabled by default it will be solved. So not worth trying to fix now.

So this is a known limitation (and will be fixed shortly), so archiving for now (we can always reopen if issues remain after work on multires sculpting is finished)