"Loading Render Kernels" now taking extremely long time on GPU.
Open, NormalPublic

Description

System Information
Windows 10 1809
AMD Vega 64 - driver version (tried) everything from 18.5.1 (recommended) to 18.10.1 (optionals)

Blender Version
Broken: (2.79 hash 5f8222501c2) Now all broken
Worked: All previously, now all same results

Short description of error
Rendering anything in Cycles viewport (Shift+Z) using gpu takes an excessively long time,more than it was a week ago, additionally if using camera view with render border it simply stalls forever, however once using f12 to render usually works as intended albeit slower than before. Have tested my GPU in other programs and is working as usual.

Exact steps for others to reproduce the error
Any blend file i use from default cube to any of my other work and any benchmarks like BMW will not render at the speed i was getting few weeks ago, blender is installed to C:/Program Files/Blender

Apologies if formatting is incorrect, as this is my first post here, thankyou for any assistance rendered .

Additional info: "Compiling OpenCL program split" is where the stall begins in the console window

Details

Type
Bug
Brecht Van Lommel (brecht) triaged this task as Normal priority.Fri, Oct 19, 5:46 PM

I guess something broken with a newer AMD driver.

Im guessing maybe so too, though rolling back with clean old drivers, does naught to alleviate the issue, it locks up a LOT when using the camera view and rendering with the border, i am resorting to using cpu for now though that would not be my preference.

Unaware if this bumps the topic but i am still having issues with open cl, it freezes up quite a lot, probably stuck with this as i am an amd user.