Page MenuHome

NLA editor can subtlely influence keyframes when automatic keyframes are enabled
Closed, ArchivedPublic

Description

System Information
Windows 10 GTX 960

Blender Version
Broken: 2.79b f4dc9f9d68b

Short description of error
NLA editor can influence keyframes when automatic keyframes are enabled

Exact steps for others to reproduce the error
I had an NLA strip set up, and this caused a single keyframe in my animation loop to change subtlely. Even duplicating frames would not work cause every frame change it would revert the animation back to it's previous position.

  • Make sure automatic keyframes are enabled
  • Set up an NLA strip longer than the animation you're trying to make, must be a different animation
  • Attempt to make a new action an animation loop shorter than the NLA strip
  • Observe if particular bones at the end of the loop change slightly and if they can be corrected.

I would assume this is not expected behavior. Will research this more later, just reporting immediately after this caused me grief.

I also must emphasize as far as i'm aware this only affected a single keyframe on a single bone. This bone was made with auto-rig pro. After muting all NLA edtior strips (i had several set up for FBX exporting) the keyframe was finally able to change normally.

Details

Type
Bug

Event Timeline

Philipp Oeser (lichtwerk) triaged this task as Incomplete priority.Nov 1 2018, 1:29 PM

Could you share the blendfile?
And try to describe exactly the steps to reproduce then.
(which operations to do, what should be the expected behavior, what is the [buggy] observed behavior)

Marking as incomplete for the time being...

Philipp Oeser (lichtwerk) closed this task as Archived.Nov 9 2018, 11:16 AM
Philipp Oeser (lichtwerk) claimed this task.

Since last asking for information it has been 7 or more days, due to the policy of our bug tracker we will have to archive the report until the requested information is given.