Page MenuHome

Z fighting when lowering unit scale
Closed, ArchivedPublic

Description

System Information
Win 7 gtx1080ti

Blender Version
Broken: 2.8 alpha 2

Short description of error
Z fighting on occurs on objects with close surfaces when lowering the unit scale. Maybe Z-Depth doesn't take into account unit scale.

Exact steps for others to reproduce the error
Change unit scale in the scene tab to 0.01 and add a solidify modifier with a low thickness value and artifacts appear on the object.

Details

Type
Bug

Event Timeline

Philipp Oeser (lichtwerk) triaged this task as Needs Information from User priority.

Cannot reproduce here.

Could you share your blendfile and describe what kind of artifacts you are seeing (e.g. screenshot)?

Marking as incomplete until we have that.

Ok, I looked at it a bit more and it seems to be effected by my viewport minimum clip distance, if i set the minimum clip to a metre it seems fine but it still seems to be a result of working in a lower unit scale. I added a picture of the artifacts.

Please always attach a small and simple .blend file to help reproducing the issue, always saves us a tremendous of time.

Bastien Montagne (mont29) closed this task as Archived.Dec 3 2018, 4:44 PM
Bastien Montagne (mont29) claimed this task.

More than a week without reply or activity. Due to the policy of the tracker archiving for until required info/data are provided.

Tiaan Basson (Spoopy) reopened this task as Open.
Tiaan Basson (Spoopy) raised the priority of this task from Needs Information from User to Needs Triage by Developer.

Hi guys,

Opening again. Bug appeared on a discords user file.

Blender Build hash: 609d4f5c92c7
GPU: GeForce GTX 650
OS: Linux antergos 4.20.0-zen1-1-zen #1 ZEN SMP PREEMPT x86_64 GNU/Linux

I'm including his file as well as a gif showing the error.

GIF: http://pasteall.org/pic/7e30e25c620d9e764038a21c18e79a4e
File: http://pasteall.org/blend/index.php?id=51015

[EDIT] User did report fixing it by changing the scaling as shown above.

Sebastian Parborg (zeddb) triaged this task as Needs Information from User priority.

The blend file is not minimal nor can I reproduce the issue with it. The scene scale is not setup in it either. So I tried setting a few different low scale values but couldn't see any obvious z fighting issues.

We need more specific example files with this issue.

Bastien Montagne (mont29) closed this task as Archived.Mar 18 2019, 9:17 PM
Bastien Montagne (mont29) claimed this task.

More than a week without reply or activity. Due to the policy of the tracker archiving for until required info/data are provided.