For the Sphere primitive, rename Size to Radius
Closed, ResolvedPublic

Description

All the paint primitives in Blender have a Radius property for setting the radius size. The Sphere primitive does too, but it is names 'Size' rather than 'Radius'.

Radius also makes more sense for spheres anyway.

Details

Type
To Do
William Reynish (billreynish) triaged this task as Normal priority.

Shouldn't it be the other way around, rename the other primitives properties to be "Size"? The Cube or Monkey having a radius is a bit odd.

Shouldn't it be the other way around, rename the other primitives properties to be "Size"? The Cube or Monkey having a radius is a bit odd.

E would second this, other primitives should be renamed Size, but this is still valid for spheres, Radius sounds more correct.

@Brecht Van Lommel (brecht): At the very least for Spheres, 'Radius' is correct. The default sphere primitive has a radius of 1 but a diameter of 2. The Size property is 1, so it really is a radius.

For cube, radius is strange, but it's also a bit odd if we just change it to 'Size', because the default cube actually has a default width of 2 units. Not sure what to do there? For the monkey it definitely makes no sense for there to be a radius :)

Why not use size for sphere too? (and make it control the diameter instead of the radius).

@Campbell Barton (campbellbarton): I don't mind either way, if we specify the size in radius or diameter. My main concern is that we use the correct words for things.

The current 'Size' property is really a radius, but we could also change it to use diameter instead, but then you'd have to change the value itself too.

I'm willing to give this one a shot since I'm interested in helping with development and it seems pretty simple. Should I just change the add sphere operator, or should I wait for further discussion on changing other operators to be more consistent?

Hi @Nathan Craddock (Zachman).

I think we should do it like this:

UV Sphere: Radius
Ico Sphere: Radius
Cylinder: Radius (is already the case)
Circle Radius (is already the case)
Cone: Radius (is already the case)
Torus: Radius (is already the case)

Grid: Size
Cube: Size
Monkey: Size

etc.

In other words, for all spheres or circles or cylinders, we use Radius. For everything else we use Size.

For the monkey, at the moment it is Radius, and the default value is 1, if it is changed to Size, does the value have to be changed to 2 then ?

@Lucas Boutrot (thornydre) I think it would be the same for adding a cube (and grid, plane, even things like a bezier curve and a metaball plane), it would make sense for the size of the cube to reflect the length of a side, not the radius.

Also, should these changes only show in the labels? Or should it be reflected in the python API? I think if the kwargs for the operators are going to change now is the best time.

I made the patch! D3943

Should this process be repeated for Curves, Metaballs, Grease Pencil, Bones, Empties, Lattice, Area Lights, Light probes, and force fields? If so, it might make more sense to switch the default dimension unit label from Radius to Size because it seems like most created objects would have a size and the few circular objects would have a radius as the exception.