Page MenuHome

The eevee view model failed to load the texture, causing the model to be purple
Closed, ArchivedPublic

Description

macOS 10.14 Mojave GPU: Radeon Pro Duo CPU: Intel Core i7

Blender 2.80.30 dc21ef7b86c

The eevee view model failed to load the texture, causing the model to be purple,and No fog effect

Details

Type
Bug

Event Timeline

Philipp Oeser (lichtwerk) triaged this task as Needs Information from User priority.Nov 12 2018, 9:56 AM

Cannot reproduce here (linux, 970m).

  • Is this using the current (unaltered) sample file from https://www.blender.org/2-8/ ?
  • Do the images show up in the ImageEditor?
  • Does going in and out of editmode make a difference?
  • Does changing viewmodes (going to solid/lookdev and back to rendered) make a difference?

Marking as incomplete until we narrowed this doen a bit...

  • Do the images show up in the ImageEditor?

I mean the textures, do they show up in the Image Editor?

other questions have not been answered...

Philipp Oeser (lichtwerk) raised the priority of this task from Needs Information from User to Needs Triage by Developer.Jan 9 2019, 7:28 PM

Thanx for getting back (sorry this took a while)

I still cannot reproduce, maybe someone an MACOS can confirm?

Sebastian Parborg (zeddb) triaged this task as Needs Information from User priority.Feb 4 2019, 1:23 PM

Is this still an issue with the latest blender beta?

Alain (DAR) added a subscriber: Alain (DAR).EditedFeb 5 2019, 11:47 PM

Hello,

With the latest dev built (2019.02.05: blender-2.80.0-git20190205.08ab09cf04d9-x86_64), and since 2018 July :
I confirm the rendering bug with Eevee. With the official wanderer.blend, the character is rendered purple (strictly as shown in images & movie posted above).
I can reproduce the problem with 2 machines:

  • iMac 5K 2017, 64Go RAM, macOS Sierra (10.12.6), ATI Radeon Pro 575
  • MacPro 5.1 (2012), 128 Go RAM, macOS High Sierra (all versions, the latest one 10.13.6), nVidia GTX 1080Ti 12Go.

The problem seems to stick with macOS System.
+++ Booting under Linux distros (Ubuntu, Mint) the problem does not exist , with my MacPro 5.1 +++

Alain

Sebastian Parborg (zeddb) raised the priority of this task from Needs Information from User to Normal.Feb 6 2019, 12:17 PM

If this is a shader compilation problem, generally it should say something in the system console output.

https://docs.blender.org/manual/en/latest/render/workflows/command_line.html

Run blender from a console, copy paste the output in a file and attach it here.

Hello Clément,
Here is the output of the Terminal window.
thanks{F6527363}

Clément Foucault (fclem) closed this task as Archived.Feb 6 2019, 3:17 PM

Well you have the issue explained here.

ERROR: Implementation limit of 16 active fragment shader samplers (e.g., maximum number of supported image units) exceeded, fragment shader uses 28 samplers

The driver don't support more than 16 textures at the same time and EEVEE needs ~10 of thoses slots for it's own purpose.

Most drivers nowadays support 32 textures but seems that this one does not. Nothing we can do about that.