Page MenuHome

Blender 2.8 Object constraint with offset value mess up transform orientation settings
Closed, ResolvedPublic

Description

System Information
Operating system and graphics card

Blender Version
Broken: (example: 2.69.7 4b206af, see splash screen)
Worked: (optional)

Short description of error
Constraints in 2.8 that have offset value in it, changes the pivot parameters to the constrained object and ignores bounding box and any transform orientation settings.


Exact steps for others to reproduce the error
Based on a (as simple as possible) attached .blend file with minimum amount of steps

Details

Type
Bug

Event Timeline

Naseem Shanbour (Naseem) renamed this task from Blender 2.8 Object constraint offset the object's pivot point to Blender 2.8 Object constraint with offset value mess up transform orientation settings .
Philipp Oeser (lichtwerk) claimed this task.
Philipp Oeser (lichtwerk) triaged this task as Confirmed, Medium priority.

Confirmed, will have a closer look....

note: there were similar issues (T57767, T57680 to a degree but more isolated to armatures)

Already subscribing @Campbell Barton (campbellbarton) here [maybe he knows right away]

Philipp Oeser (lichtwerk) closed this task as Resolved.Mar 9 2019, 11:37 AM

Sorry this has been lying around....

Good news: this seems to have been resolved already along the way (at least I am not able to reproduce this anymore)

@Naseem Shanbour (Naseem) : I will close this as "Resolved", feel free to comment again / reopen if issues persist.